Results 1 to 7 of 7

Can't enable macros - HELP!! (2007)

This is a discussion on Can't enable macros - HELP!! (2007) within the Excel Questions forums, part of the Question Forums category; I've created a spreadsheet (Excel 2007) with Command Buttons (ActiveX controls). All is good while I'm working on the sheet. ...

  1. #1
    New Member
    Join Date
    Aug 2008
    Posts
    27

    Default Can't enable macros - HELP!! (2007)

    I've created a spreadsheet (Excel 2007) with Command Buttons (ActiveX controls). All is good while I'm working on the sheet.
    However, if I save as an xlsm file and then reopen it later, it gives me the message:
    Because of your security settings, macros have been disabled. To run macros, you need to reopen this workbook, and then choose to enable macros...

    I have gone into the Trust Center Settings and enabled EVERYTHING, to no avail.

    Has anyone encountered this and, if so, figured out how to resolve it?

    Thanks so much!!!!

  2. #2
    Board Regular Diablo II's Avatar
    Join Date
    Sep 2008
    Location
    Tampa Fl
    Posts
    538

    Default Re: Can't enable macros - HELP!! (2007)

    at the tool bar you will see the security warning macros disabled click the options button then pick the enable this contents

  3. #3
    New Member
    Join Date
    Aug 2008
    Posts
    27

    Default Re: Can't enable macros - HELP!! (2007)

    For some reason that's not coming up when I open this worksheet.

  4. #4
    VoG
    VoG is offline
    MrExcel MVP
    Moderator
    VoG's Avatar
    Join Date
    Jun 2002
    Location
    127.0.0.1
    Posts
    63,499

    Default Re: Can't enable macros - HELP!! (2007)

    Click the Office button (top left) select Excel Options, tick Show Developer Tab on the Ribbon and click OK. Then on the Developer Tab click Macro Security and lower the security setting.

  5. #5
    New Member
    Join Date
    Aug 2008
    Posts
    27

    Default Re: Can't enable macros - HELP!! (2007)

    That is where I went previously - these are my settings:
    ActiveX Steeings: Enable all controls w/out restrictions...
    Macro Settings: Enable all macros...

    I even enabled all external content as I'm now grasping at straws...

  6. #6
    MrExcel MVP Joe Was's Avatar
    Join Date
    Feb 2002
    Location
    Central Florida, USA
    Posts
    7,539

    Default Re: Can't enable macros - HELP!! (2007)

    Can you open the VBA Editor?
    Can you write a test macro to test if you have set Excel up correctly?
    You may have set it up correctly and it is your macro that is bad?
    Also, Active-X controls and Add-ins are activated in a different area of the Trust Center.

    Try running:

    Sub myTest()
    MsgBox
    End Sub

    This should open a blank MsgBox if you have macros activated?

    Check the info below, to make sure you did it right!

    Excel 2007

    1. Click the Microsoft Office Button , and then click Excel Options.
    2. Click Trust Center, click Trust Center Settings, and then click Macro Settings.
    3. Click the options that you want:
      • Disable all macros without notification Click this option if you don't trust macros. All macros in documents and security alerts about macros are disabled. If there are documents with unsigned macros that you do trust, you can put those documents into a trusted location. Documents in trusted locations are allowed to run without being checked by the Trust Center security system.
      • Disable all macros with notification This is the default setting. Click this option if you want macros to be disabled, but you want to get security alerts if there are macros present. This way, you can choose when to enable those macros on a case by case basis.
      • Disable all macros except digitally signed macros This setting is the same as the Disable all macros with notification option, except that if the macro is digitally signed by a trusted publisher, the macro can run if you have already trusted the publisher. If you have not trusted the publisher, you are notified. That way, you can choose to enable those signed macros or trust the publisher. All unsigned macros are disabled without notification.
      • Enable all macros (not recommended, potentially dangerous code can run) Click this option to allow all macros to run. This setting makes your computer vulnerable to potentially malicious code and is not recommended.
      • Trust access to the VBA project object model This setting is for developers and is used to deliberately lock out or allow programmatic access to the VBA object model from any Automation client. In other words, it provides a security option for code that is written to automate an Office program and programmatically manipulate the Microsoft Visual Basic for Applications (VBA) environment and object model. This is a per user and per application setting, and denies access by default. This security option makes it more difficult for unauthorized programs to build "self-replicating" code that can harm end-user systems. For any Automation client to be able to access the VBA object model programmatically, the user running the code must explicitly grant access. To turn on access, select the check box.
    Tip You can open the macro security settings dialog box from the Developer tab in the Ribbon, which is part of the Microsoft Office Fluent user interface. If the Developer tab is not available, click the Microsoft Office Button, and then click Excel Options. Click Popular, and then select the Show Developer tab in the Ribbon check box.

    Note: Your IT people may control access to Security settings or not alow some settings or changes, by your Overall profile or individual profile, through the general product security management settings!
    JSW: Try and try again: "The way of the Coder!"

  7. #7
    New Member
    Join Date
    Aug 2008
    Posts
    27

    Default Re: Can't enable macros - HELP!! (2007)

    As I have checked, and re-checked every setting, I believe that you may be right about my IT people controlling this.
    I've opened a ticket with them.
    Wish me luck!

    Thanks!!

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DMCA.com