Results 1 to 2 of 2

"Enable Macro option button" disabled in Excel 2007

This is a discussion on "Enable Macro option button" disabled in Excel 2007 within the Excel Questions forums, part of the Question Forums category; Hi there, I was trying to change the Macro security settings in Excel 2007. The "Enable all macros" option button ...

  1. #1
    Board Regular
    Join Date
    Feb 2010
    Posts
    57

    Default "Enable Macro option button" disabled in Excel 2007

    Hi there,

    I was trying to change the Macro security settings in Excel 2007. The "Enable all macros" option button is disabled in my system, not sure how to get it enabled. The button "Trust access to the VBA project object model" is Enabled and also tried with that one, but I am not able to execute the macro with that.

    Any assistance on how to enable the option button is hight appreciated.

    Thanks,
    Dine

  2. #2
    Board Regular Taul's Avatar
    Join Date
    Oct 2004
    Location
    Uxbridge
    Posts
    392

    Default Re: "Enable Macro option button" disabled in Excel 2007

    1. Go to Excel Options (that's the circle in the top left corner of the screen, then bottom right of the dropdown)
    2. Go to "Trust Center" and click on the button called "Trust Center Settings"
    3. Select "Disable all Macros with Notification" and click "OK"
    (This will remain as the default setting for Excel)
    4. Close the your file and then re-open it
    (When the file is re-opened, a security notification will appear above the edit line)

    5. Click on the notification "options" and choose "Enable this Content" and click "OK"
    (Stage 5 will need to be repeated each time a macro enabled file is opened)

    The warning is not as "in ya face" as version 2003, you just have to get used to it

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DMCA.com