Results 1 to 5 of 5

Append query with unknown field name error...

This is a discussion on Append query with unknown field name error... within the Microsoft Access forums, part of the Question Forums category; Hi all. I'm trying to fix an append query that generates the right recordset just fine, but on run I ...

  1. #1
    Board Regular
    Join Date
    Jul 2008
    Location
    New Jersey
    Posts
    422

    Default Append query with unknown field name error...

    Hi all. I'm trying to fix an append query that generates the right recordset just fine, but on run I get the error:
    "The INSERT INTO statement contains the following unkown field name: '[CompanyDescription]'. Make sure you have typed the name correctly, and try the operation again." I got this error with that field under a different name (same name both tables.) Here's the sql:
    Code:
    
    INSERT INTO tblSymbolsMain ( Symbol, [CompanyDescription], [Security Type] )SELECT qryNewSymbolsToAddToMainSymbols.Symbol, qryNewSymbolsToAddToMainSymbols.CompanyDescription, qryNewSymbolsToAddToMainSymbols.[Security Type]FROM qryNewSymbolsToAddToMainSymbols;
    

    So the field names match in both tables, the source is a find unmatched query, and all field types are text. Any ideas?? Thanks in advance...Kevin

  2. #2
    Board Regular
    Join Date
    Jan 2009
    Posts
    854

    Default Re: Append query with unknown field name error...

    so in tblSymbolsMain you actually have a field called CompanyDescription ?

  3. #3
    Board Regular
    Join Date
    Jul 2008
    Location
    New Jersey
    Posts
    422

    Default Re: Append query with unknown field name error...

    Yup. I fixed it though, just a moment ago. I had to do a create table, delete the original, change the field name (again) and rebuild the query. It works now though, likes the name "Company." Thanks though...

  4. #4
    MrExcel MVP
    Moderator
    SydneyGeek's Avatar
    Join Date
    Aug 2003
    Location
    Sydney, Australia
    Posts
    12,115

    Default Re: Append query with unknown field name error...

    FWIW,

    I have seen this behaviour a bit with Append queries.
    I find that opening the query in Design view, and reselecting the field name on the grid, usually fixes the issue.

    Denis
    Self-preservation: For when you've got yourself in a jam
    ------------------------------------------------------
    My site contains a number of Excel and Access Resources

  5. #5
    Board Regular
    Join Date
    Jul 2008
    Location
    New Jersey
    Posts
    422

    Default Re: Append query with unknown field name error...

    Thanks Denis. I figured it was something like that, a stubborn quirk, better to just start over...

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DMCA.com