Results 1 to 8 of 8

Contar de una lista NUMERO PARES E IMPARES

This is a discussion on Contar de una lista NUMERO PARES E IMPARES within the Questions in Other Languages forums, part of the Question Forums category; Hola Tutores !!! Necesito que me ayuden a encontrar una fórmula que cuente los número pares e impares de una ...

  1. #1
    New Member
    Join Date
    Nov 2002
    Location
    San Jose, Costa Rica
    Posts
    32

    Default

    Hola Tutores !!!
    Necesito que me ayuden a encontrar una fórmula que cuente los número pares e impares de una lista;
    Ejemplo:

    FORMULA
    La fórmula tendrá que devolverme el número de veces que se repite el número 2, que en el ejemplo es 3 COMO NUMERO PAR, Y de Igual forma devolverá el número de veces que aparece el número 5, en el caso es 2


    NUMERO
    15413
    2
    4553
    2
    2
    45
    5
    5

    He tratado con CONTARA, CONTAR.SI, SUMAPRODUCTO, Pero no he tenido los resultados esperados, Espero me ayuden Maestros....

    Odelllp






  2. #2
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,948

    Default

    No entiendo, la idea es contar cuántos números pares hay ? o cuántas veces aparece un número específico ?
    Regards,

    Juan Pablo González
    http://www.juanpg.com

  3. #3
    New Member
    Join Date
    Nov 2002
    Location
    San Jose, Costa Rica
    Posts
    32

    Default

    Saludos Juan Pablo...

    La idea es que, de una lista de números; La fórmula cuente cuántos son números pares y números impares, Si el número 2 que es un número par, esta repetido 102 veces, La fórmula deberá devolverme ese valor, Puede decirse cuantas veces se repite....







  4. #4
    New Member
    Join Date
    Aug 2002
    Location
    Toluca Méx., México
    Posts
    20

    Default

    Intenta con una formula de arreglo matricial
    =SUMA(SI(RESIDUO(A2:A9,2)<>0,1,0)) para impares y =SUMA(SI(RESIDUO(A2:A9,2)=0,1,0)) para pares, introduce las formula con SHIFT+CTRL+ENTER, esto solo te cuenta los pares e impares, si deseas contar los que hay de cada valor extrae una lista de valores unicosy comparalos con CONTAR.SI

  5. #5
    New Member
    Join Date
    Nov 2002
    Location
    San Jose, Costa Rica
    Posts
    32

    Default

    Muchas Gracias...

    Es bueno aprender de los mejores


    Odelllp

  6. #6
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,948

    Default

    Tenía estas fórmulas por ahí, pero no las había podido poner. Las primeras (C2:C3) son las mismas que puso Leonel. La segundas (C6:C7) cuentan los números pares (o impares) únicos que hay, por ejemplo, si tengo en la lista los números

    1,2,3,2,2,3

    hay dos números impares (1,3) y uno par (2)

    ******** ******************** ************************************************************************>
    Microsoft Excel - CuentaUnicos.xls___Running: xl2000 : OS = Windows NT 4
    (F)ile (E)dit (V)iew (I)nsert (O)ptions (T)ools (D)ata (W)indow (H)elp (A)bout
    =

    A
    B
    C
    D
    E
    1
    Numero*Contar*Números**
    2
    19*130Par
    3
    21*71Impar
    4
    6****
    5
    20*Contar*Números*Únicos**
    6
    14*100Par
    7
    37*71Impar
    8
    22****
    9
    4****
    10
    15****
    11
    9****
    12
    1****
    13
    30****
    14
    10****
    15
    12****
    16
    12****
    17
    26****
    18
    34****
    19
    22****
    20
    4****
    21
    27****
    Hoja1*

    [HtmlMaker 2.32] To see the formula in the cells just click on the cells hyperlink or click the Name box
    PLEASE DO NOT QUOTE THIS TABLE IMAGE ON SAME PAGE! OTHEWISE, ERROR OF JavaScript OCCUR.



    Regards,

    Juan Pablo González
    http://www.juanpg.com

  7. #7
    New Member
    Join Date
    Nov 2009
    Posts
    1

    Default Re: Contar de una lista NUMERO PARES E IMPARES

    Si no quieres meterte con Macros, esto me funcionó a mi:

    =IF(MOD([la celda donde esté el número],2)=0,"par","impar")

    Ojalá te sea de utilidad.


    Quote Originally Posted by odelllp View Post
    Hola Tutores !!!
    Necesito que me ayuden a encontrar una fórmula que cuente los número pares e impares de una lista;
    Ejemplo:

    FORMULA
    La fórmula tendrá que devolverme el número de veces que se repite el número 2, que en el ejemplo es 3 COMO NUMERO PAR, Y de Igual forma devolverá el número de veces que aparece el número 5, en el caso es 2


    NUMERO
    15413
    2
    4553
    2
    2
    45
    5
    5

    He tratado con CONTARA, CONTAR.SI, SUMAPRODUCTO, Pero no he tenido los resultados esperados, Espero me ayuden Maestros....

    Odelllp

  8. #8
    MrExcel MVP
    Int'l Moderator
    Greg Truby's Avatar
    Join Date
    Jun 2002
    Location
    39° 17' 15" N, -94° 40' 26" W
    Posts
    9,729

    Default Re: Contar de una lista NUMERO PARES E IMPARES

    Atreju, ¿usted se dio cuenta que falta poco para que la presente cumple siete años? Si fuera un niño que iría por segundo grado de la escuela.

    Además las soluciones ofrecidas no invulcran macros.
    Greg
    ………………………………………………
    Work: XL 2003, 2007 and 2010 on Windows 7
    Please use CODE tags - especially for longer excerpts of code.

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DMCA.com