Results 1 to 5 of 5

Como comparar celdas con mas de 17 dígitos alfanuméricos??

This is a discussion on Como comparar celdas con mas de 17 dígitos alfanuméricos?? within the Questions in Other Languages forums, part of the Question Forums category; Hola, Tengo el problema de que no puedo comparar dos columnas; en la columna A tengo un listado de mas ...

  1. #1
    New Member
    Join Date
    Apr 2013
    Posts
    2

    Default Como comparar celdas con mas de 17 dígitos alfanuméricos??

    Hola, Tengo el problema de que no puedo comparar dos columnas; en la columna A tengo un listado de mas de 20mil celdas que contienen 17 dígitos alfanuméricos cada celda y en la columna B tengo alrededor de 9mil celdas igual con 17 dígitos alfanuméricos, quiero saber si la información de la columna B ya esta en la columna A, investigando me topo con que Excel tiene la limtante de que solo acepta 15 dígitos como puedo hacer la comparativo si tengo 17 dígitos en cada celda???

    Espero contar con su ayuda.... De antemano gracias!!!

  2. #2
    MrExcel MVP
    Join Date
    Aug 2010
    Location
    Rio de Janeiro BRAZIL
    Posts
    8,318

    Default Re: Como comparar celdas con mas de 17 dígitos alfanuméricos??

    Excel accepts cells with 17 alphanumeric characters!

    The Number precision that is limited to 15 digits.

    see (Excel 2007)
    Excel specifications and limits - Excel - Office.com

    ---------------------Google Translator-----------------


    Excel acepta células con 17 caracteres alfanuméricos!

    El número de precisión que se limita a 15 dígitos. (yo diria la Precisión Numerica)

    ver (Excel 2007)
    Excel specifications and limits - Excel - Office.com

    M.

  3. #3
    Board Regular sergioMabres's Avatar
    Join Date
    Feb 2013
    Location
    Córdoba, Argentina
    Posts
    489

    Default Re: Como comparar celdas con mas de 17 dígitos alfanuméricos??

    Lo que queres hacer, si no interpreto mal tu pedido, se podría resolver con =BUSCARV(..) y SI o SI.ERROR por ejemplo en la fila 1 están los títulos, y los datos empiezan en la fila dos, la formula para C2 seria =SI.ERROR(BUSCARV(B2;$A$2:$A$20000;1;0);"No esta") cuando muestre el valor de B el valor fue encontrado, cuando muestre "No esta" es que no lo encontró, luego copiar la formula de C2 hasta C9000
    Aclaremos algo contenido alfanumérico significa números y letras, contenido numeroco dignifica solo numeros, el limite de 15 dígitos de excel es para contenido númerico.
    Espero que esto sea de ayuda
    I hope this helps. If you like my work a thanks will suffice
    Sergio's blog at http://weeklytecnonews.blogspot.com....anilla-de.html

  4. #4
    New Member
    Join Date
    Apr 2013
    Posts
    2

    Default Re: Como comparar celdas con mas de 17 dígitos alfanuméricos??

    Lo logre, agradezco mucho sus comentarios, mi celda tenia contenido alfanumérico pero tomaba el valor general y a pesar de que le daba la propiedad de texto, no hacia la comparativa, por lo que hice fue colocar un apostrofe al inicio para que tomará todo como texto y de esa manera pude hacer la comparación con un buscarv sin problema alguno.

    Muchas gracias....

  5. #5
    Board Regular sergioMabres's Avatar
    Join Date
    Feb 2013
    Location
    Córdoba, Argentina
    Posts
    489

    Default Re: Como comparar celdas con mas de 17 dígitos alfanuméricos??

    me alegro que lo hayas podido resolver
    Sergio
    I hope this helps. If you like my work a thanks will suffice
    Sergio's blog at http://weeklytecnonews.blogspot.com....anilla-de.html

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


DMCA.com