MrExcel Publishing
Your One Stop for Excel Tips & Solutions

Macros????


Posted by Angela on April 27, 2001 7:18 AM

I have several users who are getting the error message "failed to register the visual basic environment" when opening spreadsheets with macros. I have added and removed the analysis toolpak and analysis toolpak-vba add-ins on my PC and on two of the problem PCs without resolving the issue. I (administrator)logged into my PC as a regular user and opened the files without any errors. One of those users can log into his local machine as the administrator and is able to open the problem files. I logged into one the other PC as the administrator and was unable to open the files. I have tried everything I can think of and I have been unable to isolate the problem. I even reinstalled MS Office 97. If it makes a difference, we do use SMS to install most of our applications. HELP!!!


Posted by Kevin James on April 27, 2001 11:40 AM

Hi Angela,

If the OS is WinNT, I have seen that when peculiar situations seem to follow a user ID, it could be a corrupt user profile.

BEFORE doing the following, go into Windows Explorer and make a copy of c:\winnt\profiles\[the user's profile] to c:\my doucments. Inevitably there will be files that will need to be restored from there. Usually PST.

Right-click My Computer, User Profiles, delete the profile and let the user log back in and try.

Posted by Dave Hawley on April 28, 2001 7:09 AM

Hi Angela

Try opening the VBE on the PC and going to Tools>References and see if any are preceded with the word "Missing". If so click the Browe button and locate them

Dave
OzGrid Business Applications

Posted by Angela on May 01, 2001 12:02 PM

FYI - I ended up adding the Data Access Object for Visual Basic component of Microsoft Office and everything appears to be running. You guys had some great ideas and I very much appreciate your pushing me in the right direction.

Angela