Add up values of range of cells, if the corresponding column is emply

brianparrish

New Member
Joined
Oct 18, 2018
Messages
4
I have a range of cells in column C (C1:C100) that has dates in them. In column B (B1:B100), there are dollar amounts. Some of the cells in column C don't have dates (yet). I'd like to be able to add up the dollar amounts in column B that don't have corresponding dates is column B.

Example

B C
1 100 01/01/19
2 299 02/09/19
3 150
4 200
5 300 03/03/19

150+300=450, where the function ignores B1, B2, & B5.

Thanks in advance!
 

Some videos you may like

Excel Facts

Excel Joke
Why can't spreadsheets drive cars? They crash too often!

CalcSux78

Well-known Member
Joined
Oct 15, 2013
Messages
1,120
Try SUMPRODUCT:

Excel 2010
ABC
11001/1/2019
22992/9/2019
3150
4200
53003/3/2019
6350

<colgroup><col style="width: 25pxpx" https:="" www.mrexcel.com="" forum="" usertag.php?do="list&action=hash&hash=DAE7F5"" target="_blank"></colgroup><colgroup><col><col><col></colgroup><thead>
</thead><tbody>
</tbody>
Sheet1

Worksheet Formulas
CellFormula
B6=SUMPRODUCT(--(C1:C5=0),B1:B5)

<thead>
</thead><tbody>
</tbody>

<tbody>
</tbody>
 
Last edited:

brianparrish

New Member
Joined
Oct 18, 2018
Messages
4
Try SUMPRODUCT:

Excel 2010
ABC
11001/1/2019
22992/9/2019
3150
4200
53003/3/2019
6350

<tbody>
</tbody>
Sheet1

Worksheet Formulas
CellFormula
B6=SUMPRODUCT(--(C1:C5=0),B1:B5)

<tbody>
</tbody>

<tbody>
</tbody>

Awesome! That works great. Thanks again!!
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
12,594
Office Version
  1. 2007
Platform
  1. Windows
You can also use

=SUMAR.SI(C1:C100,"",B1:B100)
 

Watch MrExcel Video

Forum statistics

Threads
1,122,418
Messages
5,596,028
Members
414,039
Latest member
southike

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top