Copy and Paste visible cells only

lauren18

New Member
Joined
Sep 14, 2015
Messages
12
Hi All,

I'm trying to copy and paste visible cells only.

for instance;

I have columns A to Z
but I columns C to H hidden

When I use Alt+; or Find & Select>Go To Special>Visible Cells Only it selects only the visible cells. I can see the perforated line separating the columns.

However when I paste into a new, blank document with no hidden columns, ALL of the data (columns A - Z) are pasted.

I'm so frustrated I'm pulling my hair out. Help!!
 

Some videos you may like

Excel Facts

Does the VLOOKUP table have to be sorted?
No! when you are using an exact match, the VLOOKUP table can be in any order. Best-selling items at the top is actually the best.

Akuini

Well-known Member
Joined
Feb 1, 2016
Messages
2,936
Office Version
  1. 365
Platform
  1. Windows
The method ‘Find & Select>Go To Special>Visible Cells Only’ actually works for me, well, most of the time. But I read somewhere sometimes it works and sometimes not, don’t know why.
And just to be sure you need to press Ctrl+C after (not before) method ‘Find & Select>Go To Special>Visible Cells Only’
So the sequence is:
Select the cells > Find & Select>Go To Special>Visible Cells Only > ok > Ctrl+C.
But if the method still not working, I have a macro that can do that, and you can assign the macro to an icon in the toolbar so it will be simple to use it.
Let me know if you interested using the macro
 

anglais428

Well-known Member
Joined
Nov 23, 2009
Messages
634
Office Version
  1. 2016
Platform
  1. Windows
That should work. Just to be clear

Highlight the column range - CTRL G - Special - visible cells only - CTRL C - on new sheet CTRL V

It works for me.
 

KC Cat

New Member
Joined
Dec 23, 2009
Messages
46
lauren18, Akuini, and anglais428,

So, I have experienced the same thing with it working some of the time, and not some of the time. In my case, I have determined why this is.

If I copy visible cells from a workbook in one instance of Excel, then try to paste in another workbook that is open in a second instance of Excel, it does not work. And this is unfortunate, as I like to leverage the fact that I have multiple monitors.

On the other hand, it works if copying and pasting from either a) one sheet to another within the same workbook, or b) from one workbook to another within the same instance of Excel.

Conclusion: If anyone reading this knows how to make it work across multiple instances of Excel, please reply with the solution!!

Have a great day!
 

KC Cat

New Member
Joined
Dec 23, 2009
Messages
46
FYI - I am working in Excel 2010 on a Windows 7 platform. A coworker using Excel 2013 on a Windows 8 platform does not have any issues. This is because Excel 2013 inherently allows individual workbooks in the same instance to be drug to different monitors.
 

Watch MrExcel Video

Forum statistics

Threads
1,122,158
Messages
5,594,588
Members
413,915
Latest member
namreh

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top