Crazy Date question

hedgie

Board Regular
Joined
Jun 23, 2004
Messages
173
Office Version
  1. 365
Platform
  1. Windows
Ok, I am completely baffled. In most of my spreadsheets 7/1/07 when formatted as "General" comes in as 39264. However in one spreadsheet we receive from an outside party it is 37802. Yet in both spreadsheets when you format the date it shows 7/1/07. This is causing us major problems since we are trying to lookup a particular date in one spreadsheet from the other to perform a simple SUMIF.

Anyone have any clue as to what we can do to work around this?
 

Excel Facts

Bring active cell back into view
Start at A1 and select to A9999 while writing a formula, you can't see A1 anymore. Press Ctrl+Backspace to bring active cell into view.

hedgie

Board Regular
Joined
Jun 23, 2004
Messages
173
Office Version
  1. 365
Platform
  1. Windows
I think I got it - Excel on Macintosh uses the 1904 vs not the 1900 date system - I think I can use a work around. Here is the Help comments:
Change the date system
The date system changes automatically when you open a document from another platform. For example, if you are working in Excel for Windows and you open a document that was created in Excel for the Macintosh, the 1904 date system check box is selected automatically.

You can change the date system by doing the following:

Click the Microsoft Office Button , click Excel Options, and then click the Advanced category.
Under the When calculating this workbook section, select the workbook that you want, and then select or clear the Use 1904 date system check box.

Sorry for the spam - hopefully this helps someone else.

Thanks.
 

hedgie

Board Regular
Joined
Jun 23, 2004
Messages
173
Office Version
  1. 365
Platform
  1. Windows
I think I got it - Excel on Macintosh uses the 1904 vs not the 1900 date system - I think I can use a work around. Here is the Help comments:
Change the date system
The date system changes automatically when you open a document from another platform. For example, if you are working in Excel for Windows and you open a document that was created in Excel for the Macintosh, the 1904 date system check box is selected automatically.

You can change the date system by doing the following:

Click the Microsoft Office Button , click Excel Options, and then click the Advanced category.
Under the When calculating this workbook section, select the workbook that you want, and then select or clear the Use 1904 date system check box.

Sorry for the spam - hopefully this helps someone else.

Thanks.
 

Forum statistics

Threads
1,181,055
Messages
5,927,858
Members
436,573
Latest member
CMR237

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top