Decimals auto added to formatted cells..??

AlisaA

Board Regular
Joined
Mar 17, 2010
Messages
193
I am having a problem where Excel 2013 is automatically adding 2 decimal places to cells that I have formatted to NOT show decimals. The decimals show up whenever I type a formula using a percentage into either that cell or into a cell near it. It appears to be random when this actually happens.

I have gone through Excel options and deselected Automatically insert a decimal point, Extend data range formats and formulas, Enable automatic percent entry, and Use system separators. None of these have made a difference.

Is there something else I need to do to make this stop? Thank you for your help!
 

Excel Facts

What did Pito Salas invent?
Pito Salas, working for Lotus, popularized what would become to be pivot tables. It was released as Lotus Improv in 1989.
I am having a problem where Excel 2013 is automatically adding 2 decimal places to cells that I have formatted to NOT show decimals. The decimals show up whenever I type a formula using a percentage into either that cell or into a cell near it. [....] Is there something else I need to do to make this stop?

I'm afraid the answers is: probably not. The problem has existed since Excel 2003, AFAIK; perhaps "forever". I see the problem myself frequently; and like you, it irks me to no end. But we just have to put up with it.

God, grant me the serenity to accept the things I cannot change,
Courage to change the things I can,
And wisdom to know the difference.
-- Reinhold Niebuhr
 
Upvote 0

Forum statistics

Threads
1,206,942
Messages
6,075,772
Members
446,154
Latest member
Dirk46

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Back
Top