Default Excel row height doing something strange

Pippa2019

New Member
Joined
Aug 17, 2019
Messages
2
<style type="text/css">p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 12.0px Helvetica}p.p2 {margin: 0.0px 0.0px 0.0px 0.0px; font: 12.0px Helvetica; min-height: 14.0px}</style>Hope someone can work out what I've done wrong ....
In ONE particular file, default row height is misbehaving.

COLUMNS
A - dd-mmm-yy
B - text
C - text
D to Q - currency

ROWS
All text/figures 9pt Calibri, and Row Height 5.29mm [the default]


The problem
When I highlight all my entries and reduce them to 8pt, it increases row height from 5.29mm to 63.15mm ... huge! Even if I select just ONE cell, it changes that row height to 63.15mm.


FYI
- Data originally from .csv file, edited a little, there - then copy/pasted to .xls
- Mac OS 10.10.5
- Excel is 2011 for Mac, version 14.7.7 (170905)]
- There are some merged cells for the column headings, but even unmerging them, row height still goes huge.
- Have just tried to look up code Alt F11 thing - there is nothing there.
- Have tried copy/paste into new document it still does it. BUT ...

Some SEMI-GOOD NEWS:
I then tried Paste Special, to new document, ticking: "Formulas and number formats only" - and that HAS worked ... i.e. row height doesn't go mad when I change pt. size - phew ... BUT
Although this file is NOT critical, and I've clearly done something 'daft' .... I'd really like to understand why this has happened, and what's the solution, ... in case it ever happens with an important file, or huge file when I won't have time to re-do all the other formatting, again!


If anyone can put me out of my misery, I'd be VERY GRATEFUL :)
Here's hoping ...thank you,
Pippa2019
 

Excel Facts

Do you hate GETPIVOTDATA?
Prevent GETPIVOTDATA. Select inside a PivotTable. In the Analyze tab of the ribbon, open the dropown next to Options and turn it off

Glove_Man

Well-known Member
Joined
Feb 20, 2005
Messages
578
I'd be willing to bet that Wrap Text is involved in this somehow.

Sometimes, when data has been copied and pasted the text in the row is present, but the formatting hasn't been "computed" for want of a better term. Excel knows that the cell is suppsed to contain "This is my example sentence" in size 10 font and with a width of 8.67 but it hasn't actually figured out how that formatting looks.

As a result, when you change any form of formatting, it triggers a recalculation of the formatting in the sheet.

When the formatting is triggered, it is making the row extra tall because one cell requires multiple lines of writing to fit into its allocated width. If you widen the column the problem should go away...

One way of finding the problem cell / cells is to select all and double click on column width. If I'm right, one of hte columns will become much wider to fit in the extra rows.
 

Pippa2019

New Member
Joined
Aug 17, 2019
Messages
2
Dear Glove-Man,

Thank you! Normally, I only 'text wrap' on the headings (or individual cells that need it, e.g. 'Notes' in last column!), but in haste, it's possible I did it on 'all cells with stuff in them'.
Alas, have just highlighted some rows (no where near the headings) and made sure text wrap not on them - .... it's still jumping to huge row height.

Off to un-do ALL text wrap, and un-merge ALL cells in the whole doc - back to you in a minute = STILL giving me huge row height.

Will try again later ...

The reason this is perplexing me is because have been doing this for years and it's never happened before! But, I also use the same bank /.csv files, for my main account, and it would drive me bonkers if this behaviour started happening on my main file - it is seriously more important, complicated (oodles of formulae), much formatting, ... and many times the size! ... Thus my efforts to find out what I've done wrong on this dodgy file, and to know what the solution is ... in case it happens again, and worse still, on the main file!

Thank you, and best wishes,
Pippa
 

Watch MrExcel Video

Forum statistics

Threads
1,132,707
Messages
5,654,840
Members
418,156
Latest member
juliapearson

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top