double spacing

still learning

Well-known Member
Joined
Jan 15, 2010
Messages
626
Office Version
  1. 365
Platform
  1. Windows
Hi
Hope all loved ones are well
When I type out my question using Word and then coy and paste it here, it double spaces it.
Am I wrong NOT to leave it double spaced?
I always try and shorten it up'

mike
 

Fluff

MrExcel MVP, Moderator
Joined
Jun 12, 2014
Messages
58,493
Office Version
  1. 365
Platform
  1. Windows
Whilst I don't paste to the board from Word, I've just tried it & don't get any problem with spacing.
It maybe down to the layout/format of your Word file.
Whilst you don't need to delete the extra line spaces, I would recommend you do.
If the line spacing is too much, it can make it difficult to read/understand.

PS the above is pasted from word as-is
 

Joe4

MrExcel MVP, Junior Admin
Joined
Aug 1, 2002
Messages
57,664
Office Version
  1. 365
Platform
  1. Windows
I did some testing and noticed some very peculiar behavior.

First, I tested typing in Word, and copying to here.
Since Word's default is double-spaced, it posted double-space to here, as expected.

However, if I changed Word to single-space, typed something in and copy and pasted here, it STILL pasted it here as double-spaced.

If I took something from some other program that was single-spaced and pasted that to Word, and then copied that from Word to here, that stayed single-spaced.

So, from my limited testing, it appears that anything I typed into Word first and and copied and pasted to here would show up double-spaces, regardless of whether or not it was double-spaced in Word or not.

Very strange. I wonder if @smozgur (Suat) can tell us how it is being rendered.
 

still learning

Well-known Member
Joined
Jan 15, 2010
Messages
626
Office Version
  1. 365
Platform
  1. Windows
Thanks for the replies
I never thought about how Word is configured.
I will continue to delete the extra lines.
I hope I'm in the loop if @smozhur finds out

mike
 

smozgur

BatCoder
Joined
Feb 28, 2002
Messages
1,453

ADVERTISEMENT

@smozgur is here!
  • Short answer first - we have to live with it. (Not that bad - please see workarounds below)
  • Technical (kind of) description: The JavaScript editor is trying to convert what it is being pasted in it. Word processor's paragraph elements in the clipboard look like double space according to the editor, so it is kind of doing its best to render the content correspondingly - I admit it is not the best result. I wish it ignores the format in the clipboard, right? Wait a minute, can we force it to ignore the format and structure? Keep reading.
  • Workaround 1: There is a way to force the editor to ignore the formatting and structure but accept pure text content instead of rendering what is being pasted - simply acting as an HTML text element. Click on the BBCode button right next to XL2BB button on the editor toolbar and make sure it is highlighted (active) as show below, then paste the content. Of course it will lose all the formatting - which is the point.
    1594684955027.png
  • Workaround 2: This is not that quick but pasting into a text editor (not rich text editor, text editor like Notepad) and copying there will also help since Notepad will remove all formatting etc... It means two middleware in between. Not beautiful but still an answer.
  • Workaround 3 and the most beautiful one: I wouldn't have said this until last year but XenForo's (the new forum software we are using at MrExcel Message Board since November 2019) has a really powerful editor that gives you all features that you can expect from a word processor, and it has a perfect auto-save feature that will keep what you typed is saved automatically - which was my biggest concern always to use a text editor when I prepare an answer. Therefore I strongly recommend typing in the internal editor instead using a middleware. Faster, all tools are ready on the toolbar, auto-save etc... And exactly what you see is what you post.
Hope this helps.
 

Joe4

MrExcel MVP, Junior Admin
Joined
Aug 1, 2002
Messages
57,664
Office Version
  1. 365
Platform
  1. Windows
Thanks for the info, Suat!
 

Watch MrExcel Video

Forum statistics

Threads
1,133,427
Messages
5,658,733
Members
418,467
Latest member
sc356448

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top