Edit hyperlinks in Excel......lots of 'em -"&"

JimGunther

Board Regular
Joined
Oct 22, 2006
Messages
57
I noticed that my hyperlinks which were working fine when my document was in WORD or Web Page format no longer worked after they were saved as an EXCEL document.

Apparently, EXCEL has taken each occurance of "&" in my hyperlinks and appended "amp;" to the address. (i.e. "&ID=" becomes "&ID="

Is there any simple way to either suppress this extra stuff upon conversion from Web Page to EXCEL or editing the underlying link in a "find and replace mode" after it has become an EXCEL file.

BTW: Thanks to Erik and Norie who helped yesterday. It is clear to me that I'm not proficient enough to be fooling around with VBE.

TIA, Jim
 

Excel Facts

Lock one reference in a formula
Need 1 part of a formula to always point to the same range? use $ signs: $V$2:$Z$99 will always point to V2:Z99, even after copying

Watch MrExcel Video

Forum statistics

Threads
1,133,649
Messages
5,660,113
Members
418,550
Latest member
kp_

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top