Excel 2013 truncating file names

JPartlin

New Member
Joined
Jan 27, 2014
Messages
1
Hi

We have had a few instances where Excel 2013 is truncating a filename when saving for example
"MF Not Settled - Dec 13 Rental A.." the filename includes additional characters than this but has replaced them with .., I initially thought it could be a file path length issue but the files in question the total length is less than 150 characters including the server name.

This is also happening with links inside excel files to different tabs in the same workbook and well as macro names causing them to have to be ran manually as it has truncated the name to .. at the end.

Please find some examples below:

Full filename: MF Jan 2014 vols Smart churn sensitivity
Truncated filename: MF Jan 2014 vols Smart churn...

Also if you try to link to the truncated workbook whilst open it displays the formula as:

='[MF Jan 2014 vols Smart churn...sitivity.xlsm]Input c’!$E$13

My work around is to save the file to another folder, without closing it, and then it works fine. However, in doing this it will try to save as the truncated name, so I first have to select the correct name of the file in the existing folder, before saving to a separate folder. However, if the file is closed, and then reopened the problem returns.

Can anyone advise on how to stop this happening or how to fix it?

Thanks in advance

Jamie
 

Some videos you may like

Excel Facts

Whats the difference between CONCAT and CONCATENATE?
The newer CONCAT function can reference a range of cells. =CONCATENATE(A1,A2,A3,A4,A5) becomes =CONCAT(A1:A5)

jwswarens

New Member
Joined
Jun 30, 2011
Messages
3
I am having the same issue. I have not 100% verified but believe this truncation to happen to files that are password protected so that users are forced to open then as Read-only.

JPartlin-are your files in question password-protected?
 

jwswarens

New Member
Joined
Jun 30, 2011
Messages
3
Just checking in to see if anyone else is having issues with this or knows a solution?
 

Russclub

New Member
Joined
Sep 15, 2015
Messages
1
Hi - did you manage to find a solution to this as it's driving me crazy. It seems to only happen to me when files are password protected, linking anything to them becomes impossible. The obvious answer is to remove the protection (which is what I've been doing) but this isn't ideal as the files are protected for a reason.

Many thanks.

Russell
 

jwswarens

New Member
Joined
Jun 30, 2011
Messages
3
We did not find a resolution on purpose. We do monthly rollout of Microsoft updates to all of our users and the Office suite of apps has updates almost every month. Somewhere along the way this filename issue resolved itself because we don't have the problem any longer.

My PC says I have Excel 2013 (15.0.4745.1000) MSO (15.0.4745.1000) 32 bit

Hi - did you manage to find a solution to this as it's driving me crazy. It seems to only happen to me when files are password protected, linking anything to them becomes impossible. The obvious answer is to remove the protection (which is what I've been doing) but this isn't ideal as the files are protected for a reason.

Many thanks.

Russell
 

Watch MrExcel Video

Forum statistics

Threads
1,122,421
Messages
5,596,033
Members
414,039
Latest member
southike

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top