Excel Chart Changes X Axis Formatting

TMLstan

New Member
Joined
Jul 9, 2017
Messages
22
Office Version
  1. 365
Platform
  1. Windows
I am having trouble with the X Axis being formatted differently in two different charts using the same source data.

In the first chart, the X Axis presents exactly as it is formatted in the source data: 2010, 2011, 2012, etc.
In the second chart, the X Axis, while referencing the same source data, formats the X axis as 1,2,3,4...

When I select data for the axis in the second chart, it shows the horizontal axis labels exactly as the source data, exactly as i want them to appear. When i hit, OK and look at the chart, it shows 1,2,3,4...

I have ensured the source data is formatted as General number.

It is unclear why it works in one chart and not the other.

Any suggestions?

BTW, i would have pasted screenshots but don't know how to post them on here.
 

Some videos you may like

Excel Facts

Round to nearest half hour?
Use =MROUND(A2,"0:30") to round to nearest half hour. Use =CEILING(A2,"0:30") to round to next half hour.

TMLstan

New Member
Joined
Jul 9, 2017
Messages
22
Office Version
  1. 365
Platform
  1. Windows
Never mind. I got it to work.

When i 'select data' for the axis, it was showing showing the correct horizontal axis values which was perplexing because the chart was not displaying these same axis values (they were formatted as a 'number' instead of a date. However, upon further review, that result was just for the first series of data in the 'select data'; when i scrolled down and selected the second series of data, it was showing the incorrect 'number' formatting for the horizontal axis which was producing the undesired result on the chart. When I changed the formatting of the horizontal axis values for the second and third series to date, it correctly changed the values on the chart.

Hope that makes sense. In any case, i am good.



I am having trouble with the X Axis being formatted differently in two different charts using the same source data.

In the first chart, the X Axis presents exactly as it is formatted in the source data: 2010, 2011, 2012, etc.
In the second chart, the X Axis, while referencing the same source data, formats the X axis as 1,2,3,4...

When I select data for the axis in the second chart, it shows the horizontal axis labels exactly as the source data, exactly as i want them to appear. When i hit, OK and look at the chart, it shows 1,2,3,4...

I have ensured the source data is formatted as General number.

It is unclear why it works in one chart and not the other.

Any suggestions?

BTW, i would have pasted screenshots but don't know how to post them on here.
 

Watch MrExcel Video

Forum statistics

Threads
1,109,047
Messages
5,526,464
Members
409,701
Latest member
nitmani

This Week's Hot Topics

Top