Excel Chart Changes X Axis Formatting

TMLstan

New Member
Joined
Jul 9, 2017
Messages
22
Office Version
365
Platform
Windows
I am having trouble with the X Axis being formatted differently in two different charts using the same source data.

In the first chart, the X Axis presents exactly as it is formatted in the source data: 2010, 2011, 2012, etc.
In the second chart, the X Axis, while referencing the same source data, formats the X axis as 1,2,3,4...

When I select data for the axis in the second chart, it shows the horizontal axis labels exactly as the source data, exactly as i want them to appear. When i hit, OK and look at the chart, it shows 1,2,3,4...

I have ensured the source data is formatted as General number.

It is unclear why it works in one chart and not the other.

Any suggestions?

BTW, i would have pasted screenshots but don't know how to post them on here.
 

Some videos you may like

Excel Facts

Links? Where??
If Excel says you have links but you can't find them, go to Formulas, Name Manager. Look for old links to dead workbooks & delete.

TMLstan

New Member
Joined
Jul 9, 2017
Messages
22
Office Version
365
Platform
Windows
Never mind. I got it to work.

When i 'select data' for the axis, it was showing showing the correct horizontal axis values which was perplexing because the chart was not displaying these same axis values (they were formatted as a 'number' instead of a date. However, upon further review, that result was just for the first series of data in the 'select data'; when i scrolled down and selected the second series of data, it was showing the incorrect 'number' formatting for the horizontal axis which was producing the undesired result on the chart. When I changed the formatting of the horizontal axis values for the second and third series to date, it correctly changed the values on the chart.

Hope that makes sense. In any case, i am good.



I am having trouble with the X Axis being formatted differently in two different charts using the same source data.

In the first chart, the X Axis presents exactly as it is formatted in the source data: 2010, 2011, 2012, etc.
In the second chart, the X Axis, while referencing the same source data, formats the X axis as 1,2,3,4...

When I select data for the axis in the second chart, it shows the horizontal axis labels exactly as the source data, exactly as i want them to appear. When i hit, OK and look at the chart, it shows 1,2,3,4...

I have ensured the source data is formatted as General number.

It is unclear why it works in one chart and not the other.

Any suggestions?

BTW, i would have pasted screenshots but don't know how to post them on here.
 

Watch MrExcel Video

Forum statistics

Threads
1,102,778
Messages
5,488,823
Members
407,658
Latest member
Arias610

This Week's Hot Topics

  • Timer in VBA - Stop, Start, Pause and Reset
    [CODE=vba][/CODE] Option Explicit Dim CmdStop As Boolean Dim Paused As Boolean Dim Start Dim TimerValue As Date Dim pausedTime As Date Sub...
  • how to updates multiple rows in muliselect listbox
    Hello everyone. I need help with below code. code is only chaning 1st row in mulitiselect list box. i know issue with code...
  • Delete Row from Table
    I am trying to delete a row from a table using VBA using a named range to find what I need to delete. My Range is finding the right cell. In the...
  • Assigning to a variable
    I have a for each block where I want to assign the value in column 5 of the found row to the variable Serv. [CODE=vba] For Each ws In...
  • Way to verify information
    Hi All, I don't know what to call this formula, and therefore can't search. I have a spreadsheet with information I want to reference...
  • Active Cell Address – Inactive Sheet
    How to use VBA to get the cell address of the active cell in an inactive worksheet and then place that cell address in a location on the current...
Top