Excel doesn't properly parse .csv files on opening

Dickison

Board Regular
Joined
Jun 12, 2002
Messages
75
Recently I cannot get Excel to properly open a .csv file. All the data goes into column A without parsing. I know I can easily convert it to columns using text to column or importing it, but I just want it to do it automatically like it used to. I've checked the data with Notepad and confirmed that the data is ok. How do I get it to open automatically parsed?
 

Some videos you may like

Excel Facts

How to change case of text in Excel?
Use =UPPER() for upper case, =LOWER() for lower case, and =PROPER() for proper case. PROPER won't capitalize second c in Mccartney

nbrcrunch

Well-known Member
Joined
Jan 1, 2003
Messages
2,062
When you open the file, your choice in the "Type of File" box is set to?......
 

Dickison

Board Regular
Joined
Jun 12, 2002
Messages
75
the option to specify the file type is when you import a file. I can import it, but by default Excel has always been able to correctly parse a .csv file. I've been opening .csv files for years without a problem just by double clicking on the icon for the file. When doing that it always parsed out to separate columns. Now everything goes into column A. I would like to find what setting changed and put it back to the way it was so I don't have to go through extra steps to import or convert to columns.
 

Dickison

Board Regular
Joined
Jun 12, 2002
Messages
75
I found the problem. The file was saved as unicode rather than ansi. When I changed it to ANSI it worked ok.

Thanks
 

Watch MrExcel Video

Forum statistics

Threads
1,118,167
Messages
5,570,635
Members
412,334
Latest member
ExcelForLifeDontHate
Top