Excel file attributes change from writable to read only while working on it

EhbitSupport

New Member
Joined
Dec 10, 2020
Messages
3
Office Version
  1. 365
Platform
  1. Windows
A client of whom my colleagues and I are managing a network of, has some particular problem with Excel. The environment is as follows:

  • Multi-user Windows environment, a mix of Home and Pro installations
  • A server with Windows Server 2019, that is being used as a file server amongst others
  • On the fileservers, folders that are being mapped as drives to all the users
  • Users have the right permissions, according to what access they need to what folder
  • Files are opened directly from the server, without making a local copy, so any changes are saved directly to the file
One user works a lot with Excel sheets, she's the only user that has this problem. Whenever she opens a file and works on it, she has to save it as a copy after some time. So the original file changes to read only while working on it. If she starts working on the copy of the file, the same problem appears on that copy. And so on, and so on.. After some time there are too many copies and it starts to be very confusing. Anyone has an idea why this is happening? Other users have basically the same permissions and don't run into these problems.
 

Some videos you may like

Excel Facts

Spell Check in Excel
Press F7 to start spell check in Excel. Be careful, by default, Excel does not check Capitalized Werds (whoops)

GWteB

Well-known Member
Joined
Sep 10, 2010
Messages
1,295
Office Version
  1. 2013
Platform
  1. Windows
We have the same issue. I have found that this problem (in our situation) does not occur on a remote desktop (eg using a thin cliënt) but only when the Excel task runs locally. The moment a PC wakes from sleep or hibernate Excel no longer seems to be able to make the connection between the previously opened file and its location on the mapped drive or network share. The solution seems to be to disable the Windows sleep and / or hibernate feature (which our IT department refuses to do), or to save and close your file before moving away from your machine for any length of time.

Anyway, welcome to MrExcel.
 

EhbitSupport

New Member
Joined
Dec 10, 2020
Messages
3
Office Version
  1. 365
Platform
  1. Windows
We have the same issue. I have found that this problem (in our situation) does not occur on a remote desktop (eg using a thin cliënt) but only when the Excel task runs locally. The moment a PC wakes from sleep or hibernate Excel no longer seems to be able to make the connection between the previously opened file and its location on the mapped drive or network share. The solution seems to be to disable the Windows sleep and / or hibernate feature (which our IT department refuses to do), or to save and close your file before moving away from your machine for any length of time.

Anyway, welcome to MrExcel.

Thanks!

I have changed the power settings and will monitor the situation. Will let you know if this is the solution.
 

GWteB

Well-known Member
Joined
Sep 10, 2010
Messages
1,295
Office Version
  1. 2013
Platform
  1. Windows
You are welcome, fingers crossed ...
 

Watch MrExcel Video

Forum statistics

Threads
1,123,217
Messages
5,600,378
Members
414,380
Latest member
p1electric

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top