Excel not recognising that there is number stored as text

divster27

New Member
Joined
Jan 19, 2021
Messages
9
Office Version
  1. 2016
Platform
  1. Windows
Hi,

I've had a daily spreadsheet sent by a supplier for the past few years that i open and make some changes to. For one of those changes, i use the symbol highlighted below to change numbers stored as text.
For some reason, i no longer see this when i open excel - is there an option to turn this functionality on and off?

The spreadsheet hasn't changed, the data is identical - i've tried yesterday's spreadsheet which WAS fine, but no longer is. hence the question on functionality on/off...

1611055784243.png


Here's the data prior to changing
1611055913559.png


Here it is after - i noticed that some numbers don't have decimal places... I'm sure there's a very good reason for this

1611055945418.png


Any help appreacited
David
 

Attachments

  • 1611055779959.png
    1611055779959.png
    3.1 KB · Views: 0

Some videos you may like

Excel Facts

Format cells as time
Select range and press Ctrl+Shift+2 to format cells as time. (Shift 2 is the @ sign).

divster27

New Member
Joined
Jan 19, 2021
Messages
9
Office Version
  1. 2016
Platform
  1. Windows
Realise it's poor form to reply to your own post....

But when i double click into the field without decimal places, then press Enter on keyboard.... the decimal places appear
 

RoryA

MrExcel MVP, Moderator
Joined
May 2, 2008
Messages
36,151
Office Version
  1. 365
  2. 2019
  3. 2016
  4. 2010
Platform
  1. Windows
  2. MacOS
File - Options, in the Formulas section, check the Error Checking options.
 
Solution

alz

Board Regular
Joined
Jul 17, 2020
Messages
130
Office Version
  1. 2019
Platform
  1. Windows
If you want to change cell value to number.
Put 1 in blank cell . => Copy => Select the Range you want to change => paste special => Check Multiply => Ok
Before you test, make sure you have copy of your data ,in case of something went wrong!
 

divster27

New Member
Joined
Jan 19, 2021
Messages
9
Office Version
  1. 2016
Platform
  1. Windows
Thanks all - not sure what fixed it, but after the PC crashed and i restarted, the issue has gone.

Though under Formulas - Error Checking - Options "Enable background error checking" has a tick box. Currently that is ticked. Maybe that was it - thanks for your help
 

Watch MrExcel Video

Forum statistics

Threads
1,123,253
Messages
5,600,544
Members
414,387
Latest member
Vincent88

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top