Fonction UNIQUE() avec liste comprenant des cellules vides

AlainCar

New Member
Joined
May 31, 2020
Messages
6
Office Version
365
Platform
Windows
Bonjour,
j'ai remarqué qu'en utilisant UNIQUE() sur une liste comportant des cellules vides en fin de la liste retournée on trouve une valeur 0 (Zéro). Si on demande de compter le nombre de chacune des valeurs retournées et que dans la liste de départ il y a également des valeurs égales à 0 la dernière valeur retournées qui apparemment correspond aux cellules vides affiche le nombre de valeurs égale à 0. Bug ou normal ?


Autre question comment écrire la formule en H2 =NB.SI(T_Data[Data];@G2) afin qu'elle s'adapte à la liste retournée par la formule en G2 =TRIER(UNIQUE(FILTRE(T_Data[Data];ESTNUM(T_Data[Data]))))

Bien à vous

Alain

Unique avec cellules vides.png
 

Some videos you may like

Excel Facts

Best way to learn Power Query?
Read M is for (Data) Monkey book by Ken Puls and Miguel Escobar. It is the complete guide to Power Query.

Fluff

MrExcel MVP, Moderator
Joined
Jun 12, 2014
Messages
42,835
Office Version
365
Platform
Windows
Salut et bienvenue à MrExcel
Partie 1: Normal, tandis que unique renverra un 0 pour les cellules vides, le countif, compte les cellules qui contiennent 0, plutôt que les cellules vides
Partie 2: Que diriez-vous

Hope Google Translate has worked.

+Fluff New.xlsm
ABCDE
1714
2132
3641
4862
5872
6184
71
88
94
103
118
123
136
147
151
16
17
18
19
Main
Cell Formulas
RangeFormula
A1:A15A1=RANDARRAY(15,,1,8,1)
C1:C6C1=SORT(UNIQUE(FILTER(A1:A26,A1:A26<>"")))
D1:D6D1=COUNTIF(A1:A26,C1#)
Dynamic array formulas.


=TRI(UNIQUE(FILTRE(A1:A26;A1:A26<>"")))
=NB.SI(A1:A26;C1#)
 

AlainCar

New Member
Joined
May 31, 2020
Messages
6
Office Version
365
Platform
Windows
Bonjour, pas de soucis pour Google translate.
La réponse peut-être en Anglais, je comprends mais j'ai plus de difficultés pour exprimer la question en Anglais.

Merci pour la réponse rapide. Entre temps d'autres questions sont apparues. Désolé.
Je dois mettre en graphique les colonnes C en X et D en Y. Je sais comment faire bien sûr mais pas en utilisant #. Je reçois un message d'erreur.
Je voudrais aussi dans 2 colonnes obtenir le top N de la colonne D avec en regard les valeurs correspondantes de la colonne C.

Je débute avec les fonctions dynamiques mais elle offrent une telle puissance que je tiens absolument à les maitriser au plus vite.

Bien à vous
 

Fluff

MrExcel MVP, Moderator
Joined
Jun 12, 2014
Messages
42,835
Office Version
365
Platform
Windows
How about

+Fluff New.xlsm
ABCDEFGH
1
27125
3822
4123243
594364
695173
746483
8157394
9883
10794
1113110
126121
135131
141141
153152
166
174
186
193
209
214
221
2315
242
259
2614
277
286
298
302
3111
32
33
34
35
Lookup
Cell Formulas
RangeFormula
A2:A31A2=RANDARRAY(30,,1,15,1)
C2:C15C2=SORT(UNIQUE(FILTER(A2:A40,A2:A40<>"")))
D2:D15D2=COUNTIF(A2:A30,C2#)
G4:H8G4=FILTER(C2#:D2,D2#>=LARGE(D2#,G2))
Dynamic array formulas.


I know nothing about charts, so you will need to sart a new thread for that.
Je ne connais rien aux graphiques, vous devrez donc commencer un nouveau fil pour cela.
 

AlainCar

New Member
Joined
May 31, 2020
Messages
6
Office Version
365
Platform
Windows
Wonderful, thank you very much.
I will certainly come back to you later.

Best regards
 

Fluff

MrExcel MVP, Moderator
Joined
Jun 12, 2014
Messages
42,835
Office Version
365
Platform
Windows
You're welcome & thanks for the feedback.
 

AlainCar

New Member
Joined
May 31, 2020
Messages
6
Office Version
365
Platform
Windows
Hi,

I come back to you.

I forgot to tell you that I also need the cumulative sum of column H as well as the cumulative percentage, for each row, compared to the total of this column H

Best regards
 

Fluff

MrExcel MVP, Moderator
Joined
Jun 12, 2014
Messages
42,835
Office Version
365
Platform
Windows
AS that is now a totally different question, you will need to start a new thread. Thanks.
 

Watch MrExcel Video

Forum statistics

Threads
1,102,655
Messages
5,488,120
Members
407,625
Latest member
Alanacran

This Week's Hot Topics

  • Timer in VBA - Stop, Start, Pause and Reset
    [CODE=vba][/CODE] Option Explicit Dim CmdStop As Boolean Dim Paused As Boolean Dim Start Dim TimerValue As Date Dim pausedTime As Date Sub...
  • how to updates multiple rows in muliselect listbox
    Hello everyone. I need help with below code. code is only chaning 1st row in mulitiselect list box. i know issue with code...
  • Delete Row from Table
    I am trying to delete a row from a table using VBA using a named range to find what I need to delete. My Range is finding the right cell. In the...
  • Assigning to a variable
    I have a for each block where I want to assign the value in column 5 of the found row to the variable Serv. [CODE=vba] For Each ws In...
  • Way to verify information
    Hi All, I don't know what to call this formula, and therefore can't search. I have a spreadsheet with information I want to reference...
  • Active Cell Address – Inactive Sheet
    How to use VBA to get the cell address of the active cell in an inactive worksheet and then place that cell address in a location on the current...
Top