Go to Blanks doesn't highlight all blanks

andydtaylor

Active Member
Joined
Feb 15, 2007
Messages
355
Office Version
  1. 2010
Hi,

Please help this is driving me mad!

The problem is, I do go to blanks and loads of seemingly blank cells are not highlighted. The cells previously contained formulas which are no longer present (I copy/paste special'd)

In the blank cells which are not highlighted there are no spaces. If I say 'text-to-columns, format general' nothing happens, however if I double-click in each troublesome cell they get picked up as being blank.

I also tried copy/paste multiply to no avail.

Any ideas appreciated.

Thanks,

Andrdew
 

Some videos you may like

Excel Facts

Last used cell?
Press Ctrl+End to move to what Excel thinks is the last used cell.

Richard Schollar

MrExcel MVP
Joined
Apr 19, 2005
Messages
23,707
Hello Andrew

If you ar using Edit>Goto>Special>Blanks then be aware that it only identifies the blanks in the UsedRange (think this is correct) - so cells outside of it won't be selected.

Also, there are other characters that can appear as 'blanks' while not really being so (eg Ascii character 160) - potentially this might be causing you problems.
 

andydtaylor

Active Member
Joined
Feb 15, 2007
Messages
355
Office Version
  1. 2010
Hi Richard, thanks for that.

I think you're right with the jedi character! My solution was to replace "" with "@" and then to replace "@" with guess what? Yep, ""... which solved the problem.

Pretty wild, but it's solved for the time being!

Thanks,

Andrew
 

Watch MrExcel Video

Forum statistics

Threads
1,122,521
Messages
5,596,644
Members
414,083
Latest member
Mrsash

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top