Groupings in Pivot

Lazagna

New Member
Joined
Mar 9, 2016
Messages
4
I posted this in the wrong section so need to move it here:

I have a pivot table where I am attempting to show employee data, and have the employees listed, but want to show employee number as well. These are in separate columns and to have them viewable properly it won't work. What I get is this:

Division Employee Name Employee Number
1 John Doe
1 John Doe 548547

Can anyone point to a way that I can see only the second line and not the two separate lines?
 

Some videos you may like

Excel Facts

Which lookup functions find a value equal or greater than the lookup value?
MATCH uses -1 to find larger value (lookup table must be sorted ZA). XLOOKUP uses 1 to find values greater and does not need to be sorted.

Matt Allington

MrExcel MVP
Joined
Dec 18, 2014
Messages
1,247
Well this is not really a Power BI question, it is a Pivot table question. Set up the report they way you want it (with the 2 lines you mention) and then select the pivot table. Go to Design\Report Layout\Show in Tabular View. Then Sub Totals\Do Not Show Sub Totals.
 

Joyner

Well-known Member
Joined
Nov 15, 2005
Messages
1,202
I'm not quite sure from what you show above what you are seeing in the PT.

But if you want to see the Name and Number on the same line there are two solutions:

One change the format - on the Design tab, change the report to Tabular, then for Subtotals, select Do Not Show Subtotals.

The other, and what seems to be the preferred method for many. is to go to your data and concatenate those two fields, so =Name&" "&Number, copy down your data then copy paste as values - then there is never a problem keeping them together.

If I missed the mark, let me know.
 
Last edited:

Lazagna

New Member
Joined
Mar 9, 2016
Messages
4
I'm not quite sure from what you show above what you are seeing in the PT.

But if you want to see the Name and Number on the same line there are two solutions:

One change the format - on the Design tab, change the report to Tabular, then for Subtotals, select Do Not Show Subtotals.

The other, and what seems to be the preferred method for many. is to go to your data and concatenate those two fields, so =Name&" "&Number, copy down your data then copy paste as values - then there is never a problem keeping them together.

If I missed the mark, let me know.
interesting that is exactly what I did the first time and it didn't work, but it did now... weird... oh well, perhaps I did something different than I thought.

case closed!
 

Watch MrExcel Video

Forum statistics

Threads
1,122,207
Messages
5,594,841
Members
413,944
Latest member
3xc3ln00b

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top