HELP HELP HELP! Trouble creating range names

Jandy

New Member
Joined
Apr 30, 2003
Messages
41
This is driving me nuts. When I try to name a range I get the prompt "Can't find project or library." After I click OK I wind up in the VBA editor, where the References window opens. None of the entries show "missing". Office 9.0 Object Library and Excel 9.0 Object library have been selected, but I can't deselect them.

I've tried these 3 things without success:

I'm able to clear the check-box for Office 9.0, but when I try to clear Excel 9.0 I get the prompt "Can't remove control or reference: in use". After I close and re-open Excel again Office 9.0 has been re-selected.

The Mso9.dll and Stdole2.tlb files are on my hard disk. I tried disabling them by renaming, but then Excel wouldn't open.

This macro didn't work, despite the statement that it "programmatically removes the reference to the Microsoft Office 9.0 Object Library and OLE Automation from the workbook. You can then save the workbook in the Microsoft Excel 5.0/95 Workbook format. When you open the workbook in Microsoft Excel 5.0 or 7.0, and then run a macro, insert a module, or record a new macro, the error message does not appear."
Sub RemoveLibraryReferences()
On Error Resume Next
Dim xObject As Object
Set xObject = ThisWorkbook.VBProject.References.Item("Office")
ThisWorkbook.VBProject.References.Remove xObject
Set xObject = ThisWorkbook.VBProject.References.Item("stdole")
ThisWorkbook.VBProject.References.Remove xObject
End Sub
There are no options to save the workbook as ver. 5.0 or 7.0. I've tried saving as 5.0 / 97 workbook and 4.0 workbook instead. No matter what I do I get the same prompts.

Woe is me. I'm desperate and will be eternally grateful if you can lead me out of this tortured labrynth.

TIA :oops:
 

Some videos you may like

Excel Facts

Which came first: VisiCalc or Lotus 1-2-3?
Dan Bricklin and Bob Frankston debuted VisiCalc in 1979 as a Visible Calculator. Lotus 1-2-3 debuted in the early 1980's, from Mitch Kapor.

shajueasow

Well-known Member
Joined
Oct 7, 2004
Messages
1,926
Hi,
For a similar problem (related to macros), what Igot from experienced hands was like the following.
If your file has macros in it, then
1. open file in "Macros dissabled" mode
2. press ALT+F11
3. click Tools_References
4. uncheck Missing ...
5. save file
6. reopen file in "MacrosEnabled" mode

Not sure whether this will help you, but still.....
 

Jandy

New Member
Joined
Apr 30, 2003
Messages
41
Thanks for the idea but unfortunately nothing was shown as "missing," even in Macros Disabled mode.
 

Watch MrExcel Video

Forum statistics

Threads
1,118,535
Messages
5,572,747
Members
412,482
Latest member
arooshrana2
Top