Macro security warning is missing

mrblister

Board Regular
Joined
Nov 20, 2016
Messages
177
Office Version
  1. 2019
Platform
  1. Windows
I'm working on a spreadsheet with macros and VBA. Until yesterday, whenever I opened the spreadsheet I would get a warning under the formula bar, and would have to press "Enable" to get macros to work. That message no longer appears when I open the spreadsheet. It seems that all Macros/VBA are enabled. I want Excel to prompt me to enable Macros like it did before.

Some notes:
  • Using Excel 2010.
  • VBA editor is NOT open when I open the file.
  • In the trust center, in Macro Settings, it's set to "Disable all Macros with Notification". Which I believe is correct for what I want.
  • In the trust center, "Trust access to the VBA project model" is NOT checked.
  • In the trust center, in Message Bar, it's set to "Show all messages... if macros have been blocked".

Things I have tried:
  1. Checking the security and message settings (stated above).
  2. I tried to "refresh" the notification settings, by: In the trust center, I set it to "Enable all Macros", exited, reloaded and selected "Disable all Macros with Notification".
  3. I tried loading other spreadsheets with Macros. They behave the same (erroneous) way; no warning is given, and Macros are just enabled.


Thoughts? I want Excel to prompt me to enable Macros, as it's a potential security issue.
 

Excel Facts

Waterfall charts in Excel?
Office 365 customers have access to Waterfall charts since late 2016. They were added to Excel 2019.

MARK858

MrExcel MVP
Joined
Nov 12, 2010
Messages
14,468
Office Version
  1. 365
  2. 2010
Platform
  1. Windows
  2. Mobile
Have you saved it in a trusted location?
 

Eric W

MrExcel MVP
Joined
Aug 18, 2015
Messages
12,212
After you enable macros on a given spreadsheet so many times, it automatically becomes trusted. Other spreadsheets will still ask if you need to enable macros. To make it become untrusted again, you can go to File > Options > Trust Center > Trust Center Settings > Clear all Trusted Documents so that they are no longer trusted. Or just rename the file.

Here's a bit more info:

http://blog.contextures.com/archives/2012/12/18/excel-2010-runs-macros-without-enabling/
 

mrblister

Board Regular
Joined
Nov 20, 2016
Messages
177
Office Version
  1. 2019
Platform
  1. Windows

ADVERTISEMENT

The issue seems to be within the spreadsheet itself. I created a new spreadsheet with a Macro, saved it to the same directory with the spreadsheet I am working on, and closed Excel. I loaded the new spreadsheet, and the warning message appears. So I'm pretty sure the issue is within the spreadsheets I've been working on.
 

mrblister

Board Regular
Joined
Nov 20, 2016
Messages
177
Office Version
  1. 2019
Platform
  1. Windows
After you enable macros on a given spreadsheet so many times, it automatically becomes trusted. Other spreadsheets will still ask if you need to enable macros. To make it become untrusted again, you can go to File > Options > Trust Center > Trust Center Settings > Clear all Trusted Documents so that they are no longer trusted. Or just rename the file.

Here's a bit more info:

http://blog.contextures.com/archives/2012/12/18/excel-2010-runs-macros-without-enabling/

Yep, that was the issue. The warning is back now. Thanks Eric!
 
Master Excel Bundle

Excel contains over 450 functions, with more added every year. That’s a huge number, so where should you start? Right here with this bundle.

Forum statistics

Threads
1,164,275
Messages
5,836,336
Members
430,421
Latest member
Natas

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top