open image from within Excel

gunnars

New Member
Joined
Oct 28, 2002
Messages
4
I´ve made a link to a image file in my Excel Document. The document is a file a scanned and is 2 pages. When I click the link in Excel, the image always open in MS Paint but I want it to open in MS Imaging. I´ve changed the default program for bitmap images, but it´s still the same. Is there a way to change this? The reason for I want to open the image in MS Imaging is that the document is two scanned pages. Imaging displays both pages, but MS Paint only one.
Can you help me?
 

Excel Facts

Can a formula spear through sheets?
Use =SUM(January:December!E7) to sum E7 on all of the sheets from January through December

Damon Ostrander

MrExcel MVP
Joined
Feb 17, 2002
Messages
4,239
Hi gunnars,

I don't believe you can set a default program for "all bitmap images," but that you must set it for each type of bitmap image. You didn't mention what type of bitmap image the file you want to edit is (I am guessing .bmp), but there are numerous possibilities (.gif, .jpg, .tif, etc.). You should make sure the default for the type of image you are dealing with is set using the Windows file browser Tools > Options > File Types tab. Once this is set correctly, the file's icon should change to the picture icon for the MS Imaging application.

There is another way, however. You can always use the VBA SHELL function to force a particular application to try to open the file. For example:

Const MyFile = "C:My Documentsdoggie.bmp"
Dim RetVal
RetVal = Shell("C:WINDOWSMSIMAGING.EXE " & MyFile, 1)

I'm just guessing at the path and name of the MS Imaging executable--you will have to find out where it is and put the correct string in its place. The trailing blank in the string is required!
 

gunnars

New Member
Joined
Oct 28, 2002
Messages
4
The Icon for my image (.bmp) changes to MS Imaging. That´s not the problem.

This is what I do:
Insert - Object / Create from file. I browse the image.bmp file and mark the "Display as Icon" feature.
Now I see my icon in the Excel document marked with MS Paint icon. Though I already have changed the default program for .bmp files.
 

Damon Ostrander

MrExcel MVP
Joined
Feb 17, 2002
Messages
4,239
Hi again gunnars,

You didn't mention what happens when you double-click on the file outside of Excel. It should open in MS Imaging (of course). If it does not, then you have not actually succeeded in changing the default application for opening .bmp files.

Damon
 

gunnars

New Member
Joined
Oct 28, 2002
Messages
4

ADVERTISEMENT

Hi Damon!
I´ve actually doubled check the settings and I also see that the Icon have changed to MS Imaging in my file folder. So I don´t know what is wrong now......
 

Damon Ostrander

MrExcel MVP
Joined
Feb 17, 2002
Messages
4,239
Hi again gunnars,

It is easy to change the icon associated with a file type without actually changing the application that opens the file to the one that is represented by the icon. In order to verify that the application assignment has succeeded, you really have to double-click on the file as I mentioned, since the icon is no guarantee.

Damon
 

gunnars

New Member
Joined
Oct 28, 2002
Messages
4

ADVERTISEMENT

Hi again Damon.

Really, I´m not stubid. I have of course tried to open the image file. It opens of course in imaging.
But if I import it as an object into a Excel document, it opens in MS Paint.
 

Ivan F Moala

MrExcel MVP
Joined
Feb 10, 2002
Messages
4,209
On 2002-10-30 03:34, gunnars wrote:
Hi again Damon.

Really, I´m not stubid. I have of course tried to open the image file. It opens of course in imaging.
But if I import it as an object into a Excel document, it opens in MS Paint.

Don't import it as an object BitMap image...import it as an object type associated with the applicable application
eg.=EMBED("Imaging.Document","")

Have a look @ the Registered list of imported applications that allow OLE that should be in the Listbox list.
 

Let_it_rain

New Member
Joined
Dec 4, 2008
Messages
2
Hate to dig up this OLD post, but I am having the exactly same problem. I wasn't importing objects. I tried everything but still can't make it work.

Here's what I did. I inserted a hyperlink using =hyperlink(cell with file path, cell with file name). The links work perfectly except that all my .PNG files are opening in Internet Explore when I click on the link. I followed the steps to set the default program for PNG files. My computer--> Tools--> Folder options-->File types--> Change--> OK-->close. When I go to the folder with all the PNG files, I double click on it, it opens in Windows Picture and Fax Viewer. This is what I want, but by clicking the links in excel just wouldn't open it there.

Thanks in advance for any help.
 

Forum statistics

Threads
1,144,768
Messages
5,726,181
Members
422,660
Latest member
mrsteele

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top