PDFs opening to full screen

turkthesnake

New Member
Joined
Sep 21, 2021
Messages
4
Office Version
  1. 2016
Platform
  1. Windows
Hello,

I'm not particularly skilled, but I know enough basics such that I have created an excel sheet with links made with the HYPERLINK formula from power query file paths. The links are to pdf documents. Every time the links are used to open the documents, they open in a window that takes up the entire screen. The links are there so that multiple documents can be opened at once and compared, with the excel sheet functioning as an index of sorts, and I cannot express how annoying this open-in-full-screen thing is. It doesn't happen when the pdf is opened in any way other than using the excel sheet. It isn't reflected in the Adobe preferences for the pdf, so this is something that is happening on the excel side. It still happens if I manually add hyperlinks instead of using the function.

I'm at a loss. I've only found brief references to this in an adobe forum, but it's not an adobe problem. Does anyone know where this setting is hidden, or what is causing it? Again, really really really annoying.

Thanks in advance!
 

Excel Facts

Highlight Duplicates
Home, Conditional Formatting, Highlight Cells, Duplicate records, OK to add pink formatting to any duplicates in selected range.

Zot

Well-known Member
Joined
Nov 26, 2020
Messages
2,006
Office Version
  1. 2016
Platform
  1. Windows
Do you have Adobe Reader only or both Reader and Pro installed?
 

Zot

Well-known Member
Joined
Nov 26, 2020
Messages
2,006
Office Version
  1. 2016
Platform
  1. Windows
I came across an article on this problem. It has something to do with which application as the default to open a pdf file. Maybe that is the problem. Perhaps the default one is not at full screen. See if this help

If you are into VBA, a good reference on how to open pdf using VBA is here
 

turkthesnake

New Member
Joined
Sep 21, 2021
Messages
4
Office Version
  1. 2016
Platform
  1. Windows

ADVERTISEMENT

Thanks!

I do have Adobe set as the default app for pdfs, but I'm operating on a network shared drive and other people using my excel sheet have the same thing happen. If the pdfs are opened in any other way, they are nice, manageable, windowed pdfs. If opened with the links, they take up the whole screen. even if I change the properties of the pdfs, like specifying that they open zoomed in such and such a way, they still open as full screened, zoomed monstrosities.

Unfortunately, the VBA solutions do go a bit beyond my skill level. I was unable to get them to work. it seems like I'd have to specify the path for each link, and I'm working with hundreds of links.
 

YasserKhalil

Well-known Member
Joined
Jun 24, 2010
Messages
829
Try
VBA Code:
Sub Test()
    Call Shell("cmd.exe /S /C" & "start """" /max ""C:\Sample.pdf""", vbNormalFocus)
End Sub
 

Zot

Well-known Member
Joined
Nov 26, 2020
Messages
2,006
Office Version
  1. 2016
Platform
  1. Windows
Thanks!

I do have Adobe set as the default app for pdfs, but I'm operating on a network shared drive and other people using my excel sheet have the same thing happen. If the pdfs are opened in any other way, they are nice, manageable, windowed pdfs. If opened with the links, they take up the whole screen. even if I change the properties of the pdfs, like specifying that they open zoomed in such and such a way, they still open as full screened, zoomed monstrosities.

Unfortunately, the VBA solutions do go a bit beyond my skill level. I was unable to get them to work. it seems like I'd have to specify the path for each link, and I'm working with hundreds of links.
I was just wondering when you opened a file which apps open the file. I meant the default is Reader or Acrobat. Just ensure that the default is maximized not Full Screen.

There is also document property in File>Properties. You can set the document default there.

I see that this is the problem asked in Adobe Support Community but no one has come up with solution. I think this has nothing to do with Excel setting since no setting for hyperlink on this but the combination has caused this nuisance. :)

I have tried to create a hyperlink and my Acrobat is not opening at Full Screen like your. Tried but cannot recreate what you've seen. :unsure:

 

turkthesnake

New Member
Joined
Sep 21, 2021
Messages
4
Office Version
  1. 2016
Platform
  1. Windows
Odd. Even when I edit the properties for the pdf, those settings will apply if I open the pdf directly by browsing from Adobe or Windows explorer. However, if I open the same document using a link in excel, it will maximize. Also, if I insert the link in excel manually (instead of with a formula) and specify a view with the link dialogue, excel ignores the view I specified and goes full sized. I've seen the thread on the Adobe forums, but I think the problem is excel side mostly because if excel isn't introduced, there is no problem.

There might be a bug in my version that is common to a few others. I suppose it could also be something about the network or the operating system on my machine. Anyways, thanks for trying to help! I really appreciate your research. I tend to ask anyone I run into about this, so if I ever find out what is going on, I'll let you know.
 
Master Excel Bundle

Excel contains over 450 functions, with more added every year. That’s a huge number, so where should you start? Right here with this bundle.

Forum statistics

Threads
1,152,396
Messages
5,769,837
Members
425,574
Latest member
grimeslisa

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top