Pivot Table w/OLAP cube connection- restore defaults after user edits

sunshine292

New Member
Joined
May 23, 2012
Messages
1
I've searched everywhere for the answer to this for 48 hours now and I really need some help. We're using a pivot table with an OLAP cube connection and we're getting false-positive results because of a user error. We have 4 row labels to classify the data and we're experiencing problems with the row labels.

My issue is that when the user goes in and accidentally types/overrides a row label result from the cube. For instance, if I have 1999 Income in there, and the user accidentally types 0 in that cell, it remains as 0, even when I manually refresh the connection. However, when I put my mouse over this cell, it shows 1999 Income, which is what the cube reports.

Because of this user edit, there's a cache or something that needs to be cleared so that the row label can go back to the default (as opposed to the user edit)

If anyone can help with this, I'd be very grateful.

Thank you in advance.
 

Jerry Sullivan

MrExcel MVP
Joined
Mar 18, 2010
Messages
8,787
Hi and Welcome to the Board,

Have you tried just entering in the correct value for the Caption?

If you have many of these that need to be fixed, it could possibly be done through VBA by setting the Caption to the last reference in the PivotItem's structured Name.

If it's just a few, it might be better to fix manually.
 

Forum statistics

Threads
1,086,120
Messages
5,387,964
Members
402,091
Latest member
thomastsiakis

Some videos you may like

This Week's Hot Topics

Top