Pressing enter copies in new formula before moving selection down

Mister Metzger

New Member
Joined
Mar 18, 2016
Messages
10
Hello,

Randomly this morning, my excel has decided that sometimes when I press enter (on a cell that is selected, but not clicked into for editing) it will copy in a formula to the selected cell before moving the selection down to the next cell (as opposed to just moving the selection). It seems like the formula copied in is that of the last cell I edited (but I'm not sure). Haven't knowingly changed any settings. Thanks for any help you can provide.

Kind regards,


Mister Metzger
 

Some videos you may like

Excel Facts

Control Word Wrap
Press Alt+Enter to move to a new row in a cell. Lets you control where the words wrap.

Mister Metzger

New Member
Joined
Mar 18, 2016
Messages
10
What's being pasted are the last cell(s) I copied. So, I'll copy a cell, paste its contents to another cell, change my cell selection by mouse, but then when I hit enter, it copies the cell(s) again.
 

Mister Metzger

New Member
Joined
Mar 18, 2016
Messages
10
I've been investigating further (couldn't find a solution before using the term "copy", but I found things with "paste"), and it looks like the issue is in the very design of excel itself and there isn't a way to disable it. Has anyone found a work-around? I don't know why suddenly I ran into the issue today after using excel for years.
 

RoryA

MrExcel MVP, Moderator
Joined
May 2, 2008
Messages
36,463
Office Version
  1. 365
  2. 2019
  3. 2016
  4. 2010
Platform
  1. Windows
  2. MacOS
You could use enter to do the first paste, which should then clear the clipboard, or press Esc after the first paste.
 

Watch MrExcel Video

Forum statistics

Threads
1,127,373
Messages
5,624,309
Members
416,020
Latest member
ANDREAC247

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top