regression error - non-numeric data

ajcolyer

New Member
Joined
Jan 23, 2005
Messages
19
I am trying to do a multiple regression. My data set contains just the labels (and I've checked the label box) and hard numbers. Otherwise there is no non-numeric data, nor are there any blanks. When I do the regression I get the error "Regression - Input range contains non-numeric data."

Interestingly, when I try to enter either the Y range or the data output range, the cursor goes to one cell over from where I click.

How to I solve this and do my multiple regression?
 

Excel Facts

Format cells as time
Select range and press Ctrl+Shift+2 to format cells as time. (Shift 2 is the @ sign).

tusharm

MrExcel MVP
Joined
May 28, 2002
Messages
11,029
It's possible one of the columns (or just a single cell) contains what looks like numbers but in text form. If that's the problem, the fix would be to copy a truly empty cell (no formula, no formatting, no numbers or text -- just a really empty cell), then select all the cells containing what you believe are numbers and doing a right-click | Paste Special... | in the resulting dialog box in the Operation section, select the Add option.
 

Lucas Ventura

New Member
Joined
Feb 15, 2014
Messages
1
Hello guys! My name is Lucas Ventura and I'm from Brazil. This is my first post! Well... To fix this problem you must follow these steps:

1). Select the cells where you will put your data and format them as Number.

2). When you type your data, don't put this configuration >> 3.6. You must put your number in this way: 3,6. In other words, with comma.

God bless you!

Enjoy it guys!


It's possible one of the columns (or just a single cell) contains what looks like numbers but in text form. If that's the problem, the fix would be to copy a truly empty cell (no formula, no formatting, no numbers or text -- just a really empty cell), then select all the cells containing what you believe are numbers and doing a right-click | Paste Special... | in the resulting dialog box in the Operation section, select the Add option.
 

Aladin Akyurek

MrExcel MVP
Joined
Feb 14, 2002
Messages
85,209
Hello guys! My name is Lucas Ventura and I'm from Brazil. This is my first post! Well... To fix this problem you must follow these steps:

1). Select the cells where you will put your data and format them as Number.

2). When you type your data, don't put this configuration >> 3.6. You must put your number in this way: 3,6. In other words, with comma.

God bless you!

Enjoy it guys!

You are welcome. But, post formatting, that is, after an entry is made, is just for eyes. Excel will keep the original formatting, unless it's really changed for example as described in the tusharm post. Also, a numeric entry like 3,6 (one with comma) is not universal. On a US system, it's rather 3.6 (with a dot).
 

Forum statistics

Threads
1,136,878
Messages
5,678,305
Members
419,753
Latest member
Sallylwy

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top