Sending mail.

mlw901

New Member
Joined
Oct 28, 2002
Messages
41
Hi again

I have a macro that sends a workbook as an attachment to an email address specified in a certain cell. However, i would like to disable the outlook express 'send/do not send' message alert so i can display my own.How can this be done?

Cheers
 

Some videos you may like

Excel Facts

Move date out one month or year
Use =EDATE(A2,1) for one month later. Use EDATE(A2,12) for one year later.

Tom Morales

Board Regular
Joined
Feb 16, 2002
Messages
91
I'm not familiar with Outlook Express, but Outlook (Office 2000 and greater) has a similar alert. I presume that it's to prevent the propagation of viruses of the "I Love You" variety. If there were a way around it, I'm sure hackers would have come up with a new virus that would exploit the loophole.

_________________
This message was edited by Tom Morales on 2002-11-12 14:26
 

Jack in the UK

Well-known Member
Joined
Feb 16, 2002
Messages
3,215
Hi Yes this can be done but i underline Toms comments. so i will never tell the work arroun

I also NOW am technical staff and as such i would throw anyone i found deliberatly tripping Microsofts defences in this manner off the roof, its not on

Not being dificult, its there to protect you, use it would be my advice

JITUK
 

ShidanTowfiq

New Member
Joined
Dec 1, 2004
Messages
3
I have a legit corporate use for this topic and found a workaround elsewhere that is not necessarily virus-friendly, AND it still suits my requirements of automatically sending a batch of unique e-mails with attachments to a predetermined list of department managers. I didn't want the Accountant to click 'Yes' 80+ times. The e-mail message is displayed briefly, so if this process is used for a virus, it's going to be blatently obvious to the person whose PC it's running on. Anyway, here's the code:

Instead of using:
aEmail.Send

Use:
aEmail.Display
Application.SendKeys "%s", True

And now a batch of unique e-mails is completely automated without any messages popping up, unless there is a spelling error and spell check is activated in Outlook for all messages.

I hate it when people won't share information...

Shidan
Code:
 

Bagsy

Active Member
Joined
Feb 26, 2005
Messages
377
Office Version
  1. 365
Platform
  1. Windows
You may be able to turn the warning off in outlook express depending what version you are using.
Try
Tools
Options
Security
and clear "warn me when other applications try to send mail as me"
You have this option in Outlook Express 6
 

Watch MrExcel Video

Forum statistics

Threads
1,122,511
Messages
5,596,581
Members
414,079
Latest member
Frills

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top