Strange behaviour and annoying

pcc

Well-known Member
Joined
Jan 21, 2003
Messages
1,345
I am using Excel 2002 (Don't laugh!). I run a lot of VB code, most of which involves loading and unloading userforms, connecting to (eg) MS Access, etc, so all in all I give Excel a pretty hard ride. Sometimes (and I can't pin down any specific things that seem to cause this to happen), when code execution has completed, the leftmost (approximately 20%) of the working area of whichever sheet is uppermost is greyed out. That is, the row numbers are not visible, and the column numbers (those that fall within this area) are not visible either, There is just a pale grey rectangle where there should not be! Changing worksheets does not remove it, nor does adding new workbooks or opening other workbooks. The only way to get rid of it is to close the whole Excel app and re-open it.
I have lived with this for some time but it is annoying. Can anyone suggest a reason as to why this might be happening, and, more importantly, how to prevent it?
All suggestion welcomed.
Regards
 

Some videos you may like

Excel Facts

How to create a cell-sized chart?
Tiny charts, called Sparklines, were added to Excel 2010. Look for Sparklines on the Insert tab.

JLGWhiz

Well-known Member
Joined
Feb 7, 2012
Messages
12,979
Office Version
  1. 2013
Platform
  1. Windows
When you see the grey bar on the left, go to Data>Ungroup.
 

pcc

Well-known Member
Joined
Jan 21, 2003
Messages
1,345
Thanks. I will try next time it happens and let you know..
Regards
 

JLGWhiz

Well-known Member
Joined
Feb 7, 2012
Messages
12,979
Office Version
  1. 2013
Platform
  1. Windows
Thanks. I will try next time it happens and let you know..
Regards
You probably have some code in one of your files that groups data. If the code does not then ungroup the data before End Sub, then the Group mode remains in effect and the grey bar will display. If you can locate the code. just add a line at the end to ungroup the specified ranges and that will prevent the bar from appearing.
 

pcc

Well-known Member
Joined
Jan 21, 2003
Messages
1,345

ADVERTISEMENT

Thanks for replying, but that's not it. I am not grouping any data. The greyed-out area literally covers 20% of the screen. I suspect it's a memory problem since the only way to clear it seems to be to close and re-open Excel. Anyone else have any ideas? Please see attached screenshot showing the problem.
Excel_problem.jpg

Regards.
 

JLGWhiz

Well-known Member
Joined
Feb 7, 2012
Messages
12,979
Office Version
  1. 2013
Platform
  1. Windows
Something is blocking the screen painting for sure. Not so sure it is because of memory. Does it do it for random files, or just for that one file?
 

mole999

Moderator
Joined
Oct 23, 2004
Messages
10,524
Office Version
  1. 2019
  2. 2016
  3. 2013
Platform
  1. Windows

ADVERTISEMENT

update your graphic card drivers, how much memory, O/S versions etc
 

pcc

Well-known Member
Joined
Jan 21, 2003
Messages
1,345
Something is blocking the screen painting for sure. Not so sure it is because of memory. Does it do it for random files, or just for that one file?
Does it randomly on random files..
 

Watch MrExcel Video

Forum statistics

Threads
1,127,201
Messages
5,623,343
Members
415,969
Latest member
Rey99

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top