VLOOKUP returning strange data when not typed in manually

TimmyBird

New Member
Joined
Oct 1, 2014
Messages
3
Hi!

I'm having problems with VLOOKUP.
The formula looks as follows:
=VLOOKUP(K22;Scope!$A$2:$B$66;2;0)

Now, when I type the formula in manually it works out just fine but if Icopy/paste or autofill it returns the same data as the one cell i'm using to fill from. This is really stressing me out! I can't type this in manually in 797 cells.

Please help!
 

Some videos you may like

Excel Facts

What is =ROMAN(40) in Excel?
The Roman numeral for 40 is XL. Bill "MrExcel" Jelen's 40th book was called MrExcel XL.

Beyond_avarice

Board Regular
Joined
Nov 13, 2012
Messages
195
Office Version
  1. 2007
Platform
  1. Windows
It looks you are using Openoffice "Calc" syntax.

Use commas instead of semicolons.
 

TimmyBird

New Member
Joined
Oct 1, 2014
Messages
3
That's what I did at first but Excel wouldn't buy it. Probably down to me using a Swedish version.

Funny thing: If I paste the formula and get the wrong data in return, I can press F2 to enter the formula, then press enter and get the desired result. Very strange indeed!
 

JoeMo

MrExcel MVP
Joined
May 26, 2009
Messages
17,388
Office Version
  1. 365
  2. 2010
Platform
  1. Windows
That's what I did at first but Excel wouldn't buy it. Probably down to me using a Swedish version.

Funny thing: If I paste the formula and get the wrong data in return, I can press F2 to enter the formula, then press enter and get the desired result. Very strange indeed!
Check to see if you have calculation set to manual. Formulas>Calculation>Calculation Options>Automatic.
 

Beyond_avarice

Board Regular
Joined
Nov 13, 2012
Messages
195
Office Version
  1. 2007
Platform
  1. Windows
Swedish huh. Try VTSÖK. for 2010 and LETARAD for older.
 

Watch MrExcel Video

Forum statistics

Threads
1,122,481
Messages
5,596,399
Members
414,063
Latest member
N_Bates

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top