Why doesn't Mr Excel HTML maker work? - Reply requested!

ClaireS

Board Regular
Joined
Jul 29, 2013
Messages
136
I have downloaded the add-in, extracted the add-in to the Add-ins folder, UnBlocked it and installed it in Excel. I have a menu option called "MrExcel HTML Maker". On that ribbon is one group called "Generate HTML (Specify Options)". The options listed are:

All Formulas
First Cell Only
First Cell in Each Column
No Formulas
User Defined Selection

No other buttons or controls.

I have tried selecting a range in a workbook, then clicking on various buttons, but whatever I choose, when I paste it into this forum, it comes out as [FONT=Verdana,Arial,Tahoma,Calibri,Geneva,sans-serif]��.

I am running Excel 2016/365 on Windows 10.

Thank you for your help.
[/FONT]
 

Some videos you may like

ClaireS

Board Regular
Joined
Jul 29, 2013
Messages
136
Have done so. Many thanks for your help. No idea what I was doing wrong!
 

Eric W

MrExcel MVP
Joined
Aug 18, 2015
Messages
9,545
I sporadically get the same problem. I haven't had time to figure out the specifics, but it has to do with how it sends the HTML to the clipboard. I can sometimes get around it by printing the HTML to the immediate window, then copying that and pasting it. Then there also seems to be a problem with how the HTML is formulated, since I have often have to clean it up. It's sporadic, and also seems to be related to computer settings. My work PC almost always has a problem, while my home PC rarely does. Based on some of the other posts I've seen here, where they post a table that has random HTML showing, other people are having the same issues.
 

RoryA

MrExcel MVP, Moderator
Joined
May 2, 2008
Messages
34,793
Office Version
365, 2019, 2016, 2010
Platform
Windows, MacOS
It's a bug with the DataObject and Windows8 and later. It seems to happen if you have a File Explorer window open.
 

MARK858

MrExcel MVP
Joined
Nov 12, 2010
Messages
12,379
Office Version
365, 2010
Platform
Windows, Mobile
Based on some of the other posts I've seen here, where they post a table that has random HTML showing, other people are having the same issues
The random Html I see posted is normally the fonts and is what you get if you are using the old version of Html Maker.
 

ClaireS

Board Regular
Joined
Jul 29, 2013
Messages
136
Thanks all for your comments - maybe it wasn't me after all. But it works now anyway!
 

ClaireS

Board Regular
Joined
Jul 29, 2013
Messages
136
It's a bug with the DataObject and Windows8 and later. It seems to happen if you have a File Explorer window open.
Thanks @RoryA, it happened again today. File Explorer open, closed it, success!
 

Watch MrExcel Video

Forum statistics

Threads
1,095,282
Messages
5,443,542
Members
405,238
Latest member
siddo

This Week's Hot Topics

Top