Why wont it let me save Macro even though it is enabled

tomkelly88

New Member
Joined
May 20, 2010
Messages
5
Hi

I am using Excel 2007, I have enabled Macro using Excel Options -> Trust Centre Setting etc...But yet when i go to save my file it says that "the following cannot be saved in macro-free workbooks: VB Project To save a file with these features, Click No and the choose a macro-enabled file type the File Type List. To continue saving as a macro free file click Yes"

I know have enabled the workbook to allow for me to use macro...

Why wont it let me save it?

Anyone thanks
 

Excel Facts

Waterfall charts in Excel?
Office 365 customers have access to Waterfall charts since late 2016. They were added to Excel 2019.

VoG

Legend
Joined
Jun 19, 2002
Messages
63,650
Click the Office button (top left) and click Excel Options.

Click on Save then select Macro enabled workbook (.xlsm) from the dropdown and click OK.
 

Forum statistics

Threads
1,136,339
Messages
5,675,193
Members
419,553
Latest member
hanahass

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top