Results 1 to 5 of 5

Thread: Macros disabled - Greyed out in Trust Settings - Can't turn it back on
Thanks Thanks: 0 Likes Likes: 0

  1. #1
    Board Regular
    Join Date
    May 2014
    Posts
    372
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Macros disabled - Greyed out in Trust Settings - Can't turn it back on

    I was writing a program and got hung in a loop, so I ended Excel through Task Manager and now I'm getting the message "Because of your security setting, macros have been disabled." I tried going into the Trust Center to re-enable macros, but all the options are greyed out and I can't select anything. Anyone know how to fix that, so I can continue writing macros?

  2. #2
    Board Regular Michael M's Avatar
    Join Date
    Oct 2005
    Location
    South Western NSW
    Posts
    17,806
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default Re: Macros disabled - Greyed out in Trust Settings - Can't turn it back on

    Is the file saved as an .xlsm file extension ?
    Have you tried retrieving it ?
    otherwise macros will be disabled.
    Last edited by Michael M; May 13th, 2019 at 07:44 PM.
    Regards
    Michael M
    ---------------------------------------
    The more I learn, the less I seem to know.....A Please and Thank You cost nothing !
    It's easier to debug if we can see the whole macro !
    Home 2007 & 2013

    - Posting guidelines, forum rules and terms of use

    - To download Mr Excel HTML Maker

    - Try searching for your answer first, see how

    - Read the FAQs

    - List of BB codes


    [CODE]Place Your Code Here[/CODE]

  3. #3
    Board Regular
    Join Date
    May 2014
    Posts
    372
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Macros disabled - Greyed out in Trust Settings - Can't turn it back on

    The file is saved as an .xlsm file
    I had saved it before running the code, so I don't think I needed to retrieve it. I opened it right up from windows explorer.
    Is there a different way to retrieve / open it?

    Quote Originally Posted by Michael M View Post
    Is the file saved as an .xlsm file extension ?
    Have you tried retrieving it ?
    otherwise macros will be disabled.

  4. #4
    Board Regular Michael M's Avatar
    Join Date
    Oct 2005
    Location
    South Western NSW
    Posts
    17,806
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default Re: Macros disabled - Greyed out in Trust Settings - Can't turn it back on

    Have you tried


    1. Go to the file tab and click on 'Open'
    2. Now click on the Recent Workbooks option on the top left.
    3. Now scroll to the bottom and click on 'Recover Unsaved Workbooks' button.
    4. Scroll through the list and search for the file you lost.
    5. Double-click on it to open it.
    Regards
    Michael M
    ---------------------------------------
    The more I learn, the less I seem to know.....A Please and Thank You cost nothing !
    It's easier to debug if we can see the whole macro !
    Home 2007 & 2013

    - Posting guidelines, forum rules and terms of use

    - To download Mr Excel HTML Maker

    - Try searching for your answer first, see how

    - Read the FAQs

    - List of BB codes


    [CODE]Place Your Code Here[/CODE]

  5. #5
    Board Regular
    Join Date
    May 2014
    Posts
    372
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Macros disabled - Greyed out in Trust Settings - Can't turn it back on

    I tried that and it didn't work. Turned out that I had to just start over with a new excel file and just re-create the file and module. Thanks for trying though!!

Some videos you may like

User Tag List

Tags for this Thread

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •