Automatically converting to Text formatting
Eliminate Pivot Table Annoyances
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Automatically converting to Text formatting

  1. #1
    New Member
    Join Date
    Mar 2002
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

     
    Is there a way to prevent this? On my computer at work, whenever Excel thinks that your data should be Text, it adds an apostrophe to the beginning of the cell, causing it to be seen as text no matter what type of formatting you actually select for it. So, if I need a column to be numbers, I basically have to insert a new cell, use the VALUE function and copy paste values.

    I need to know if there is something I can do to prevent Excel from trying to guess what data type I want and stop putting the apostrophe at the beginning of the line?

  2. #2
    Board Regular
    Join Date
    Mar 2002
    Location
    London, UK
    Posts
    167
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    are you importing from a text file? if so the import mechanism should allow you to specify the data types.

  3. #3
    New Member
    Join Date
    Mar 2002
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No, that's what's weird to me. If I type something on a line it looks normal. But if I go to another cell and come back to the cell I typed in, the apostrophe is there. I have never encountered this on my Excel at home or at any other job. That's why I thought that it was some sort of option, but I can't figure out what.

  4. #4
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Austin, Texas USA
    Posts
    11,654
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It's probably a combination of factors...

    1. Choose the Tools | Options... menu command and uncheck the "Transition navigation keys" setting on the Transition tab.

    2. Change the cell(s) or column formatting to something other than Text (such as General).

    Also, once you made these changes there's an easier way to convert your values back to numbers. Just select 'em, choose the Data | Text to Columns... menu command, and press [ Finish ].

    [ This Message was edited by: Mark W. on 2002-04-04 15:21 ]

  5. #5
    New Member
    Join Date
    Mar 2002
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

      
    Thanks!!!!

    Unchecking the transition navigation keys option cured my problem.

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 

 
DMCA.com