Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: ActiveX Command Button Doesn't Click

  1. #1
    New Member
    Join Date
    Mar 2004
    Posts
    14
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default ActiveX Command Button Doesn't Click

    I'm having a problem in a workbook with several ActiveX command buttons. I had been using the form control buttons to run macros, but the boss wanted each button to have it's own, different color. So I removed the form control buttons and created new ActiveX command buttons. I got into the button properties and set the background colors. I added the _Click code to run the macros when the user clicked the buttons.

    All of the buttons were working fine. Then I saved and closed the workbook and went to lunch. Now when I open the workbook, the buttons don't work! When I click them nothing happens. They appear frozen. They don't even seem to click. No error message. Nothing.

    If I right-click the button in Design Mode and select Properties, I get sheet properties not the button properties. I can't seem to locate the command button properties any longer. I still see the button name "cmdButtonGetInfo" and "=EMBED("Forms.CommandButton.1","") in the name box and formula bar. The odd thing is if I create a new button it works fine until I save and close the file. When I reopen the file none of the buttons work.

    It's like the buttons are being disabled when I close or open the file. Any suggestions?

  2. #2
    New Member
    Join Date
    Mar 2004
    Posts
    14
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: ActiveX Command Button Doesn't Click

    I think it's related to the ActiveX setting in the Trust Center. "Disable all controls without notification" is selected. And everything is grayed-out so I can't change it. Guess we'll have to settle for gray buttons...

  3. #3
    New Member
    Join Date
    Mar 2011
    Posts
    37
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: ActiveX Command Button Doesn't Click

    disregard

Some videos you may like

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •