Error Checking in Excel
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Why do I need 2 single quotes for 1 to show up?

  1. #1
    Board Regular UniMord's Avatar
    Join Date
    May 2002
    Location
    Swampy side of Far Rockaway
    Posts
    308
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi!

    I have a column holding date ranges, e.g. '98-'99, '96-'02, etc. For some reason, the initial quotes, which are visible in the formula bar, are invisible in the cells, they show up as: 98-'99, 96-'02. I've been working around this by inserting 2 single quotes. Why is this happening? How do I fix this?

    Thanx,

    UniMord

  2. #2
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Austin, Texas USA
    Posts
    11,654
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The leading apostrophe is an alternate way of making a text entry and is never displayed.

    For more on this use of an apostrophe do a Help | Find on the keyword "apostrophe" and read the topic for "An apostrophe ('), a caret (^), or a quotation mark (") appears in the formula bar but not in the cells."

    [ This Message was edited by: Mark W. on 2002-05-07 13:30 ]

  3. #3
    Board Regular
    Join Date
    Apr 2002
    Location
    Minnesota
    Posts
    821
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Excel is interpreting the first single quote as a label indicator. A carryover from the good old days when you had to have a label indicator for text.

  4. #4
    Board Regular UniMord's Avatar
    Join Date
    May 2002
    Location
    Swampy side of Far Rockaway
    Posts
    308
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanx for the quick responses. I tried setting the column to text, but it doesn't fix the problem. Any other ideas?

  5. #5
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Austin, Texas USA
    Posts
    11,654
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    On 2002-05-07 13:28, UniMord wrote:
    Thanx for the quick responses. I tried setting the column to text, but it doesn't fix the problem. Any other ideas?
    Yeah, when I had a moment I went to verify my recommendation and made the same discovery (and re-edited my original posting).

    As I now see it you have 3 choices...

    1. Live with ''98-'99 (2 apostrophes)
    2. Use ="'98-'99" (quoted text string)
    3. Enter 98-'99 and format as ;;;"'"@ (format w/quoted apostrophe)

    [ This Message was edited by: Mark W. on 2002-05-07 13:37 ]

Some videos you may like

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •