Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Access - Error message updating Database with linked tables

  1. #1
    New Member
    Join Date
    Jan 2018
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Access - Error message updating Database with linked tables

    I am receiving the below error message when I try to run a query that is creating a table based on information pulling from multiple databases. It seems the only way to avoid this issue is to ask all users with tables that are linked to my database to close out though I can run this same query with no issues/error messages with another group of databases to update data tables. Do you have any idea why I am getting this error message? I did not find anything online relating to what I am doing that would resolve this issue.

    Error message:
    The database has been placed in a state by user ‘Admin’ on Machine “USWDMCLFH8PP32’ that prevents it from being opened or locked. Does this relate to my database having an issue or other users where I can trying to extract data from their tables? If it is another users database – what could be wrong with it that I would see this error or vice versa if this is my issue?

    Thanks!

  2. #2
    Board Regular ranman256's Avatar
    Join Date
    Jun 2014
    Location
    Kentucky
    Posts
    1,720
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Access - Error message updating Database with linked tables

    Is this a shared multi user app?
    if so, is the db split?
    if not, then you are the only one using it, so what did you do that caused the conflict?

  3. #3
    MrExcel MVP
    Moderator
    xenou's Avatar
    Join Date
    Mar 2007
    Location
    Clev. OH, USA
    Posts
    16,048
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Default Re: Access - Error message updating Database with linked tables

    For shared use make sure all the databases are set to open in shared mode.

    This is what I get when I just type msaccess open shared mode (Google has gotten very smart in recent years, but it also helps to get the right keywords).
    • Start Access and under File, click Options. Note, if you're using Access 2007, click the Microsoft Office Button and then click Access Options.
    • In the Access Options box, click Client Settings. ...
    • In the Advanced section, under Default open mode, select Shared, click OK, and exit Access.

    Using: Office 2010/Win7 (work) Office 2010/Win7 (home)

    You are rich in proportion to the number of things you can let alone.
    -- Henry David Thoreau

Some videos you may like

User Tag List

Tags for this Thread

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •