Error Checking in Excel
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Promedio

  1. #1
    New Member
    Join Date
    Apr 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    En primer lugar agradecerle la respuesta a mi anterior duda. Y en segundo,
    Puedo que cuando se cumplan los items de dos columnas excel calcule el promedio de los valores de una de las columnas. Pero solo de los valores que cumplan las dos condiciones

  2. #2
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,959
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Claro, entonces ahí sí quedaría más facil usar la fórmula matricial inicial, pero cambiar SUMA por PROMEDIO. Depronto también podría servir mirar la función BDPROMEDIO.
    Regards,

    Juan Pablo González
    http://www.juanpg.com

  3. #3
    New Member
    Join Date
    Apr 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Y como sabe excel de que rango debe hacer el promedio?

  4. #4
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,959
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Usando esto ?

    {=PROMEDIO((A1:A10="Cond1")*(B1:B10="Cond2")*C1:C10)}

    ?

    Bueno, (A1:A10="Cond1") es una condición, cierto ?, esto genera una matriz de 10 filas x 1 columna, con valores VERDADERO o FALSO. Lo mismo pasa con (B1:B10="Cond2"). Al multiplicar estas dos matrices, obtengo otra matriz de 10x1, pero, en vez de VERDADEROs o FALSOs, obtengo 1s y 0s, por qué ? porque Excel los "convierte". Ahora, al multiplicar esta matriz por C1:C10, obtengo, cuando las dos condiciones son verdaderas, el valor en la columna C, o cuando alguna es falsa, obtengo un 0.

    Pero acabo de caer en cuenta que para el promedio, entrarían los 0's, lo cual no se necesita. Por lo tanto sería mejor cambiar la fórmula a

    {=SUMA((A1:A10="Cond1")*(B1:B10="Cond2")*C1:C10)/SUMA((A1:A10="Cond1")*(B1:B10="Cond2"))}

    Regards,

    Juan Pablo González
    http://www.juanpg.com

Some videos you may like

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •