Error Checking in Excel
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: CONTAR.SI de dos variables?

  1. #1
    New Member
    Join Date
    Apr 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Como puedo contar el numero de veces que aparecen varias condiciones. O lo que es lo mismo como puedo contar el numero de filas que cumplen dos de las condiciones expuestas en las columnas.
    Con CONTAR.SI(RANGO;CONDICION) puedo contar una columna pero si lo que quiero es saber cuantas cumplen no solo esa condicion sino tambien otra de otro rango como lo hago?

  2. #2
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,959
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ahora respondí un mensaje similar. La fórmula matricial que propuse es para un SUMAR.SI con varias condiciones, para cambiarlo a CONTAR.SI, sólo es necesario borrar la última parte, es decir, que quede así:

    {=SUMA((A1:A10="Cond1")*(B1:B10="Cond2"))}

    O, se puede reemplazar por una fórmula no matricial así:

    =SUMAPRODUCTO((A1:A10="Cond1")*(B1:B10="Cond2"))

    Regards,

    Juan Pablo González
    http://www.juanpg.com

  3. #3
    New Member
    Join Date
    Mar 2002
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Juan Pablo:

    En este ejemplo.. ?Que es mas economico en terminos de efectividad? ?La formula matricial o la SUMPRODUCT?

  4. #4
    MrExcel MVP
    Join Date
    Feb 2002
    Location
    Bogota, Colombia
    Posts
    11,959
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Pues es más facil de editar y de entender la de SUMAPRODUCTO, pero las dos trabajan sobre un rango, así que el "costo" debería ser como el mismo.
    Regards,

    Juan Pablo González
    http://www.juanpg.com

  5. #5
    New Member
    Join Date
    Apr 2002
    Location
    Spanish
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Como puedo guardar un archivo de excel con separador | (pipeline) en vez de , (comas)

Some videos you may like

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •