association with macro

L

Legacy 65404

Guest
Hello everybody,
I have a problem sometimes with macro association.
I opened a workbook today and the combobox was not associated with the macro it was before, it happened with three combo I have... and it also had already happened before some times...

does anyone have an idea of what would this be?

I have problems on this because some people use this file and they don't know how to fix it, so I have to fix it everytime.
thx in advance,
Guilherme
 

Excel Facts

Bring active cell back into view
Start at A1 and select to A9999 while writing a formula, you can't see A1 anymore. Press Ctrl+Backspace to bring active cell into view.
Hi,

This is just guessing ...
Did you "assign" the macros like this ?
Book1!Macro1
Then don't write the workbookname in the references.

but perhaps it's something else ?
the combobox was not associated with the macro it was before
was another macro assigned to it ???

kind regards,
Erik
 
Upvote 0
well, actually, I did say wrong, it was not associated with another macro, it was the default name of macro, sorry.

The name is right, with no "Book1!" on it...

I guess it could be some user here at work that changed... do you know some way to block it?
 
Upvote 0
your post is unclear to me
can you try again
I'm uncertain if it's solved or not

to block the assignment, you can simply protect the worksheet
 
Upvote 0
sorry, my english is not very good, I appreciate your attention...
I have not solved my problem yet.

I was just wondering if there is something that brakes the association between the combo and the macro, because that's what's happening... sometimes I open the file and the combos are not working...

do you understand my problem? thanks again for your help...
 
Upvote 0

Forum statistics

Threads
1,218,749
Messages
6,144,276
Members
450,535
Latest member
Erlull

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Back
Top