Cells displaying formula with VLookup

LisaM

New Member
Joined
Feb 3, 2011
Messages
12
I edited my formula for adding '$' to the column range and now instead of the formula returning the proper value, it shows my formula? I know this question has been answered here before, but for the life of me cannot find it. I have tried F2. I have gone to Tools - Options - View and checked that the box wasnt checked to show formulas. I have formatted my range in my vlookup on both worksheets the same and they are both sorted in ascending order. Anyone have any suggestions as to what else I can try?

This is what my cell is displays:
<TABLE style="WIDTH: 161pt; BORDER-COLLAPSE: collapse" border=0 cellSpacing=0 cellPadding=0 width=215 x:str><COLGROUP><COL style="WIDTH: 161pt; mso-width-source: userset; mso-width-alt: 7862" width=215><TBODY><TR style="HEIGHT: 22.5pt" height=30><TD style="BORDER-BOTTOM: #ece9d8; BORDER-LEFT: #ece9d8; BACKGROUND-COLOR: transparent; WIDTH: 161pt; HEIGHT: 22.5pt; BORDER-TOP: #ece9d8; BORDER-RIGHT: #ece9d8" class=xl24 height=30 width=215>

<TABLE style="WIDTH: 161pt; BORDER-COLLAPSE: collapse" border=0 cellSpacing=0 cellPadding=0 width=215 x:str><COLGROUP><COL style="WIDTH: 161pt; mso-width-source: userset; mso-width-alt: 7862" width=215><TBODY><TR style="HEIGHT: 22.5pt" height=30><TD style="BORDER-BOTTOM: #ece9d8; BORDER-LEFT: #ece9d8; BACKGROUND-COLOR: transparent; WIDTH: 161pt; HEIGHT: 22.5pt; BORDER-TOP: #ece9d8; BORDER-RIGHT: #ece9d8" class=xl24 height=30 width=215>=VLOOKUP(A4,'Vendor Address Lookup'!$A$3:$H$462,3,FALSE)</TD></TR></TBODY></TABLE>
</TD></TR></TBODY></TABLE>
This is what my cell should display and what all the other cells display (corrosponding to the proper address):

<TABLE style="WIDTH: 227pt; BORDER-COLLAPSE: collapse" border=0 cellSpacing=0 cellPadding=0 width=302 x:str><COLGROUP><COL style="WIDTH: 227pt; mso-width-source: userset; mso-width-alt: 11044" width=302><TBODY><TR style="HEIGHT: 12.75pt" height=17><TD style="BORDER-BOTTOM: windowtext 0.5pt solid; BORDER-LEFT: windowtext 0.5pt solid; BACKGROUND-COLOR: transparent; WIDTH: 227pt; HEIGHT: 12.75pt; BORDER-TOP: windowtext 0.5pt solid; BORDER-RIGHT: windowtext 0.5pt solid" class=xl24 height=17 width=302>P O BOX 224 </TD></TR></TBODY></TABLE>
 

Some videos you may like

Excel Facts

Repeat Last Command
Pressing F4 adds dollar signs when editing a formula. When not editing, F4 repeats last command.

VoG

Legend
Joined
Jun 19, 2002
Messages
63,650
Try formatting the cell as General then re-entering the formula.
 

LisaM

New Member
Joined
Feb 3, 2011
Messages
12
I am finding this fustrating. I did what you suggested and it still displays the formula and not the result.

However on a humorous note, if I select the insert function and use VLookup, the result shows in the helper box just not in my cell.
 

LisaM

New Member
Joined
Feb 3, 2011
Messages
12
Ah Ha! I saved the workbook. Closed it and when I re opened it, it was working fine. Not sure what the problem was but thanks!
 

Aladin Akyurek

MrExcel MVP
Joined
Feb 14, 2002
Messages
85,203
I am finding this fustrating. I did what you suggested and it still displays the formula and not the result.

However on a humorous note, if I select the insert function and use VLookup, the result shows in the helper box just not in my cell.

Another procedure...

Select the formula cells, not showing results.
Activate Edit|Replace.
Set Find What to: =
Set Replace With to: =
Activate the Replace All button.
 

Watch MrExcel Video

Forum statistics

Threads
1,127,256
Messages
5,623,669
Members
415,983
Latest member
MusicMan

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top