Counting specific values

JodiEHBK

New Member
Joined
Aug 22, 2007
Messages
16
I need a formula to count specific values in a range of data. For example, say I have the values 0, 1, 2 and 3 in a column and want to know how many "1's" are in the column. I have experimented with combinations of IF and COUNT and DCOUNT without success.

It would be helpful if I can count specified text entries as well as numerical values.

Can anyone help?
 

Excel Facts

How can you turn a range sideways?
Copy the range. Select a blank cell. Right-click, Paste Special, then choose Transpose.

Joe4

MrExcel MVP, Junior Admin
Joined
Aug 1, 2002
Messages
63,304
Office Version
  1. 365
Platform
  1. Windows
Try the COUNTIF function. See Excel's help for details.
 

Lewiy

Well-known Member
Joined
Jan 5, 2007
Messages
4,284
=COUNTIF(A:A,1)
will tell you how many 1's in column A

=COUNTIF(A:A,"text")
will tell you how many cells contain "text" in column A

Hope that helps! :)
 

JodiEHBK

New Member
Joined
Aug 22, 2007
Messages
16
Wow, that problem was quickly solved. Many thanks, jm14 and Lewiy. COUNTIF does the what I want perfectly.
 

Ahonymus

New Member
Joined
Oct 27, 2014
Messages
2
I'm using Excel 2003 in French and cannot find the function COUNTIF.
I'm trying to count the cells with nothing in there in ONE column. Everything I've tried says "circular"

If someone could help solving my request... Thanks a lot.
 

Aladin Akyurek

MrExcel MVP
Joined
Feb 14, 2002
Messages
85,210
I'm using Excel 2003 in French and cannot find the function COUNTIF.
I'm trying to count the cells with nothing in there in ONE column. Everything I've tried says "circular"

If someone could help solving my request... Thanks a lot.

It's:

NB.SI

One of:

=NB.SI($A$2:$A$10;"")

=NB.SI($A$2:$A$10;"=")
 
Master Excel Bundle

Excel contains over 450 functions, with more added every year. That’s a huge number, so where should you start? Right here with this bundle.

Forum statistics

Threads
1,164,086
Messages
5,835,294
Members
430,351
Latest member
ddalton

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top