Excel 2007 Calculation Slow After Save When Not In Focus

savefocus

New Member
Joined
Mar 7, 2011
Messages
1
Hi all,

I run an fairly large Excel 2007 workbook everyday. Over the last few days, I noticed that the calculation in the workbook is acting strangely. Specifically, calculation is very slow when the workbook does not have focus (ie. I have an explorer window open and selected) but only after I save the workbook. If I open it and do not save, I can move my focus to the explorer window or another application and it continues to calculate normally. However, if I save the workbook I notice that the save takes longer than usual to start and when it's done I cannot take focus off of the workbook or calculation will be extremely slow. Saving the workbook always took a while, but I noticed that it now takes several seconds before the progress bar for the save operation shows in the bottom right of the window.

Some information about the setup:
* Rebooting the machine does not help. The workbook calculations are fine upon reopening it but as soon as I save the problem comes back and I must keep focus on the workbook to keep the calculations from getting slow.
* Calculation is set to automatic with no iteration in Excel.
* No Excel settings have been changed (for this or any other workbook)
* Machine is Windows XP with the latest service pack (the latest OS updates are installed manually every 2 weeks and were not installed around the time this started happening)

Does anyone have any idea what might be causing this slow calculation after saving when the workbook does not have focus?

Thanks,
Bob
 

Excel Facts

How to total the visible cells?
From the first blank cell below a filtered data set, press Alt+=. Instead of SUM, you will get SUBTOTAL(9,)

baodinh

New Member
Joined
Feb 27, 2011
Messages
36
Bob, check the following

1. Any links to unopened workbook? If you have unopened external links, calculations may take a long time. You can speed this up by having the linked workbooks open. To check for external links, select Edit, Links from the menu.
2. Check windows setting for percentage of processor assigned to background tasks. You may have the processor allocated almost exclusively to foreground tasks and none for background tasks.
3. Network issues - try saving the file to your local hard disk and see if the issue persists.
4. Reduce the size of your workbook - delete all the rows / columns not required. You can check using Ctrl + End to navigate to the last cell in any worksheet. Delete all columns and rows not required from this last cell then save the workbook. Your last cell should now change.
 

Forum statistics

Threads
1,141,734
Messages
5,708,162
Members
421,549
Latest member
Dtcfire

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top