Excel 2010 Can't disable automatic calculations

crozfader

Board Regular
Joined
Mar 23, 2011
Messages
86
Hey all.

I'm having a very annoying problem. I can't save the "manual calculation" option in Excel 2010. I have to manually do it every time. It used to be the default option. I work with huge spreadsheets and it this is causing me some trouble. Opening some of these spreadsheets and then trying to set the calculation mode to manual while the spreadsheet tries to calculate wastes tons of time.

Any ideas?

Thanks
 

Some videos you may like

Excel Facts

Quick Sum
Select a range of cells. The total appears in bottom right of Excel screen. Right-click total to add Max, Min, Count, Average.

JoeMo

MrExcel MVP
Joined
May 26, 2009
Messages
17,388
Office Version
  1. 365
  2. 2010
Platform
  1. Windows
Try pressing the esc key after you open the workbook - that should terminate the calculation. Then set calculation to manual.
 

xenou

MrExcel MVP
Joined
Mar 2, 2007
Messages
16,793
Office Version
  1. 2019
Platform
  1. Windows
It used to be that with Excel (I assume this is still true in 2007/2010) that workbooks follow the calculation setting of the first workbook you open - in some ways, it is as if the setting can act like a "virus" with workbooks "infecting" each other with calculation settings, either manual or auto. I usually just open blank workbook and set calc to manual, before opening any heavy workbook that I don't want to have calculate when opened (a custom keyboard short is nice for this purpose).
 
Last edited:

crozfader

Board Regular
Joined
Mar 23, 2011
Messages
86
It used to be saved.

For some reason. It is now always set to automatic. It is really annoying. You are right. Opening a workbook and setting it to manual should work, but I wonder why the setting isn't saving at all.

Thanks!
 

xenou

MrExcel MVP
Joined
Mar 2, 2007
Messages
16,793
Office Version
  1. 2019
Platform
  1. Windows

ADVERTISEMENT

I'm not sure but I believe that in my case there is a hidden workbook in my startup folder that opens "first" every time - possibly my personal.xls workbook. I've never fully probed that theory, although I get the same behavior (workbooks always open as automatic unless I explicitly set calc to manual before opening the target).
 

crozfader

Board Regular
Joined
Mar 23, 2011
Messages
86
THAT WAS IT! THANK YOU.


I have a hidden file filled with useful VBA macros that opens up automatically from the XLSTART folder. This one was set to automatic which explains everything.


Again, thanks!!!!!
 

classic9

New Member
Joined
May 1, 2013
Messages
1
THAT WAS IT! THANK YOU.


I have a hidden file filled with useful VBA macros that opens up automatically from the XLSTART folder. This one was set to automatic which explains everything.


Again, thanks!!!!!

Hi,

How did you fix it?
 

Watch MrExcel Video

Forum statistics

Threads
1,122,647
Messages
5,597,363
Members
414,139
Latest member
okela0

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top