Keeping Merged Cells when Copying in Macro

Status
Not open for further replies.

pbassett

Active Member
Joined
May 5, 2004
Messages
358
How can I keep merged cell formatting when I copy rows in a Macro? The macro below does not work - the new rows contain individual cells.

>>>
' Paste 6 rows with merged cells
Rows("4:9").Select
Range("C4:C9").Activate
Selection.Copy
Rows(NewRow & ":" & NewRow + 5).Select
Range("C" & NewRow & ":C" & NewRow + 5).Activate
Selection.PasteSpecial Paste:=xlPasteFormats, Operation:=xlNone, _
SkipBlanks:=False, Transpose:=False
Application.CutCopyMode = False
<<<
 

Excel Facts

Excel motto
Not everything I do at work revolves around Excel. Only the fun parts.
Status
Not open for further replies.

Forum statistics

Threads
1,148,393
Messages
5,746,438
Members
424,019
Latest member
dpteo

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top