SHELL as record value causing problem in Norway OS

jdsouza

Board Regular
Joined
Jul 19, 2012
Messages
102
Good day

Been stumped by this problem for some time now.

I have two tables - 1. Company 2. Employees

Table 1. Field - Just one (CompanyName)
Table 2. Fields - two (EmployeeName & CompanyName via dropdown combobox populated with values from Table1)

Relationships - none

In the Excel Userform, I have two combo boxes

1. Company Name
2. Employee Name

When user selects an item from combo 1, combo 2 items are refilled with values from the Employees table filtered for value of combo 1.

This works perfectly for all values of combo1 (Company Name) - the values in Combo 2 are correctly populated with Employee names of selected company. (I use English OS and English Office 2010).

When the application is used in Norway, it works OK for all values of Combo 1 (company name) except if the user selects SHELL from list of company names.

I tried by amending all entries in the respective tables CompanyName field to have ZZZ at the beginning of each record (Example : ZZZCHEVRON or ZZZSHELL or ZZZWHATEVER). It still does not work for SHELL in the office in Norway where OS and Office 2010 are Norwegian Bokmal.

For SHELL, the combo2 remains blank.

BTW, in the combo boxes for sake of correct display, I remove the ZZZ characters add the ZZZ at the beginning of the filter statement.

As stated already the code works OK on my PC in India in all situations and also in the office PC in Norway in all situation except if the user selects SHELL

Would appreciate any help in this matter.
 

Some videos you may like

Excel Facts

How to total the visible cells?
From the first blank cell below a filtered data set, press Alt+=. Instead of SUM, you will get SUBTOTAL(9,)

Watch MrExcel Video

Forum statistics

Threads
1,127,147
Messages
5,623,008
Members
415,946
Latest member
bellerom

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top