Sorting doesnt link columns next to each other

Lupison

Board Regular
Joined
Jun 14, 2006
Messages
50
I have about 30 columns with data in them. All located right next to each other, no spacer columns. But sorting one column only includes the 25 right columns. The 5 left columns dont "move" with the other columns.

Obviously this is a major problem. Is there someway to force columns to link up with each for sorts?
 

Excel Facts

Ambidextrous Undo
Undo last command with Ctrl+Z or Alt+Backspace. If you use the Undo icon in the QAT, open the drop-down arrow to undo up to 100 steps.

Joe4

MrExcel MVP, Junior Admin
Joined
Aug 1, 2002
Messages
58,951
Office Version
  1. 365
Platform
  1. Windows
Are you including all 30 columns in your sort range?
It will only sort the column you have selected.

Also, what is in the last 5 columns? Values, formulas, or links?
 

Lupison

Board Regular
Joined
Jun 14, 2006
Messages
50
last 5 columns are text descriptors. Normally when you select a cell, just one cell, and hit the sort button at the top, Excel intellegently chooses "linked" columns to move with the sorted column. Same if you choose a full column and his sort, it asks for surrounding columns as well. When I do click "include other columns" same problem happens. First time I've ran into this problem. All other times excel picks up on the text based descriptor columns as well. Only if there's a space of empty columns between columns does it "not" include them.
 

Joe4

MrExcel MVP, Junior Admin
Joined
Aug 1, 2002
Messages
58,951
Office Version
  1. 365
Platform
  1. Windows
I wouldn't trust the "intelligent" automatic selection. It may depend on factors like what row/column you are currently in, if there are any blanks on that row, whether all columns have Column Headers, etc.

I think it is best to pick exactly the range you want, then you are not leaving anything to chance.
 

Forum statistics

Threads
1,141,096
Messages
5,704,312
Members
421,338
Latest member
Pepess

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top