Why are command button caption fonts different on new monitor?

futureme

New Member
Joined
Apr 17, 2017
Messages
19
I created a custom form last year on an older computer that was using a 4k monitor with resolution of 3840 x 2160. Last month I built a new computer which now uses a 2k monitor at 2560x1440. I kept the old PC so the other monitor stays with it.

When I opened my form on the new PC the captions on my command buttons are now all shifted down far enough so that the bottom of the caption text is cut off on all the buttons. Here's an image of the buttons as seen on each monitor:

bar.jpg


The top row is how they appear on the 4k monitor and the bottom is how they appear on the new 2k monitor. In both instances the buttons are 18 high using Tahoma Regular size 10 font for the captions.

As you can see the font is thinner on the new monitor and clearly shifted down.

I don't know if this is an Excel issue or a monitor issue. I'm currently in contact with the monitor manufacturer but they don't appear to have any ideas as to what's going on other than to say that things look different on 4k and 2k monitors.

In my opinion though they should not look this different otherwise how could people make forms that look pretty much the same no matter what monitor is being used.

Anyone have any ideas as to what's going on here? I've already tried adjusting the high DPI option on excel.exe but that doesn't do anything. It looks to me like the caption is moved slightly down but as far as I know there's no way to adjust that. There is nothing special about these buttons. I've made a new form and plopped buttons on it with no events and they still look the same on both computers as seen in the image above.
 

Excel Facts

What did Pito Salas invent?
Pito Salas, working for Lotus, popularized what would become to be pivot tables. It was released as Lotus Improv in 1989.

JLGWhiz

Well-known Member
Joined
Feb 7, 2012
Messages
12,979
Office Version
  1. 2013
Platform
  1. Windows
Pribably the screen resolution setting. The settings can vary from monitor to monitor, espcially if they are different manufacturer products.
 

futureme

New Member
Joined
Apr 17, 2017
Messages
19
Pribably the screen resolution setting. The settings can vary from monitor to monitor, espcially if they are different manufacturer products.

I've considered that. It just seems odd that you can't make a form that's going to look basically the same on any monitor. I don't understand why the captions are shifted so far down on the new monitor.
 

Kyle123

Well-known Member
Joined
Jan 24, 2012
Messages
2,714
Do you have different scaling set up on Windows? I\d have thought you would with such a difference in resolutions. Windows really doesn't deal with this well, especially so in VBA which is decades old and bitmap rather than vector based, dpi scaling just wasn't a thing when it was implemented
 

futureme

New Member
Joined
Apr 17, 2017
Messages
19

ADVERTISEMENT

I don't have scaling on the new PC which is where the problem is seen. On the old PC the form was created at a time when I had scaling set to 150%, but if I reduce the resolution from 4k to 2k to match the resolution of the new monitor the scaling on the old PC is automatically changed to 100%. The form looks fine on the older PC no matter what the scaling is.

I thought the Tahoma font was supposed to be vector based (according to what I read at any rate). I still was thinking it does look oddly pixelated on the new monitor so what you say does make more sense regarding bitmap versus vector based.

I guess that's where the problem may lie.

I guess I'll just have to deal with it. Unfortunately no other font looks as good on buttons as Tahoma imo and if I make it small enough so the bottom isn't getting cutoff it doesn't look good at all.
 

Eric W

MrExcel MVP
Joined
Aug 18, 2015
Messages
10,803
One thing you can try is to check the compatibility settings for Excel.

1596037696894.png


Go to the Properties menu for Excel, go to the Compatibility tab, click the "Change high DPI settings" button, then on the next dialog box, check the "Override high DPI scaling behavior" and choose Application. This helped with a lot of the forms I built.
 

futureme

New Member
Joined
Apr 17, 2017
Messages
19

ADVERTISEMENT

One thing you can try is to check the compatibility settings for Excel.

Thanks, that was one of the first things I tried. I was very surprised that this didn't do anything at all. I was expecting that the font would at least look less pixelated, but nothing happened.
 

Eric W

MrExcel MVP
Joined
Aug 18, 2015
Messages
10,803
Well, that's a shame! I've had the same issue with some of the forms and sheet objects. It's quite frustrating to spend a lot of time getting something to look just right, and have it get all messed up when you open it on another monitor. It's clearly some kind of weird interaction between Windows and Excel. I've scoured the web, and it appears to be a common problem. A lot of people tried a lot of things, including registry settings. The Compatibility settings worked for me, but it doesn't for everyone. Let us know if you find anything that works for you.
 

futureme

New Member
Joined
Apr 17, 2017
Messages
19
Well, that's a shame! I've had the same issue with some of the forms and sheet objects. It's quite frustrating to spend a lot of time getting something to look just right, and have it get all messed up when you open it on another monitor. It's clearly some kind of weird interaction between Windows and Excel. I've scoured the web, and it appears to be a common problem. A lot of people tried a lot of things, including registry settings. The Compatibility settings worked for me, but it doesn't for everyone. Let us know if you find anything that works for you.

Thanks, at least it's good to know it isn't just me!
 

Watch MrExcel Video

Forum statistics

Threads
1,129,387
Messages
5,636,020
Members
416,892
Latest member
Bensch

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top